Re: [PATCH 04/17] Rename memory allocation/free functions

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Aug 7, 2013 at 6:09 AM, Matt Fleming <matt@xxxxxxxxxxxxxxxxx> wrote:
> On Tue, 06 Aug, at 08:45:00PM, Roy Franz wrote:
>> Rename them to be more similar, as low_free() could be used to free
>> memory allocated by both high_alloc() and low_alloc().
>> high_alloc() -> efi_high_alloc()
>> low_alloc()  -> efi_low_alloc()
>> low_free()   -> efi_free()
>>
>> Signed-off-by: Roy Franz <roy.franz@xxxxxxxxxx>
>> ---
>>  arch/x86/boot/compressed/eboot.c       |   19 ++++++++++---------
>>  drivers/firmware/efi/efi-stub-helper.c |   16 ++++++++--------
>>  2 files changed, 18 insertions(+), 17 deletions(-)
>
> [...]
>
>> @@ -163,10 +163,10 @@ fail:
>>  }
>>
>>  /*
>> - * Allocate at the lowest possible address.
>> + * Allocate at the lowest possible address, that is not below 'min'
>>   */
>> -static efi_status_t low_alloc(efi_system_table_t *sys_table_arg,
>> -             unsigned long size, unsigned long align,
>> +static efi_status_t efi_low_alloc(efi_system_table_t *sys_table_arg,
>> +                           unsigned long size, unsigned long align,
>>                             unsigned long *addr)
>>  {
>>       unsigned long map_size, desc_size;
>
> Whoops, did this change to the comment slip in from some other patch?
>
> --
> Matt Fleming, Intel Open Source Technology Center

Yes it did - that should be in a later patch that makes that change.

Roy
--
To unsubscribe from this list: send the line "unsubscribe linux-efi" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux