From: Leo Kim <leo.kim@xxxxxxxxx> This patch renames variable gu8FlushedAuthType to auth_type to avoid CamelCase naming convention. Add to static because follow warning reported by kbuild system. - drivers/staging/wilc1000/host_interface.c:267:4: sparse: symbol 'auth_type' was not declared. Should it be static? Signed-off-by: Leo Kim <leo.kim@xxxxxxxxx> Signed-off-by: Tony Cho <tony.cho@xxxxxxxxx> --- drivers/staging/wilc1000/host_interface.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wilc1000/host_interface.c index e15aeb1..f06280b 100644 --- a/drivers/staging/wilc1000/host_interface.c +++ b/drivers/staging/wilc1000/host_interface.c @@ -264,7 +264,7 @@ static u8 del_beacon; static u8 *join_req; static u8 *info_element; static u8 mode_11i; -u8 gu8FlushedAuthType; +static u8 auth_type; u32 gu32FlushedJoinReqSize; u32 gu32FlushedInfoElemAsocSize; struct host_if_drv *gu8FlushedJoinReqDrvHandler; @@ -1100,7 +1100,7 @@ static s32 Handle_Connect(struct host_if_drv *hif_drv, u32WidsCount++; if (memcmp("DIRECT-", pstrHostIFconnectAttr->ssid, 7)) - gu8FlushedAuthType = (u8)hif_drv->strWILC_UsrConnReq.tenuAuth_type; + auth_type = (u8)hif_drv->strWILC_UsrConnReq.tenuAuth_type; PRINT_INFO(HOSTINF_DBG, "Authentication Type = %x\n", hif_drv->strWILC_UsrConnReq.tenuAuth_type); PRINT_D(HOSTINF_DBG, "Connecting to network of SSID %s on channel %d\n", @@ -1317,7 +1317,7 @@ static s32 Handle_FlushConnect(struct host_if_drv *hif_drv) strWIDList[u32WidsCount].id = (u16)WID_AUTH_TYPE; strWIDList[u32WidsCount].type = WID_CHAR; strWIDList[u32WidsCount].size = sizeof(char); - strWIDList[u32WidsCount].val = (s8 *)(&gu8FlushedAuthType); + strWIDList[u32WidsCount].val = (s8 *)(&auth_type); u32WidsCount++; strWIDList[u32WidsCount].id = (u16)WID_JOIN_REQ_EXTENDED; -- 1.9.1 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel