From: Leo Kim <leo.kim@xxxxxxxxx> This patch renames variable gu8Flushed11iMode to mode_11i to avoid CamelCase naming convention. Add to static because follow warning reported by kbuild system. - drivers/staging/wilc1000/host_interface.c:266:4: sparse: symbol 'mode_11i' was not declared. Should it be static? Signed-off-by: Leo Kim <leo.kim@xxxxxxxxx> Signed-off-by: Tony Cho <tony.cho@xxxxxxxxx> --- drivers/staging/wilc1000/host_interface.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wilc1000/host_interface.c index db63886..e15aeb1 100644 --- a/drivers/staging/wilc1000/host_interface.c +++ b/drivers/staging/wilc1000/host_interface.c @@ -263,7 +263,7 @@ static u8 del_beacon; static u8 *join_req; static u8 *info_element; -u8 gu8Flushed11iMode; +static u8 mode_11i; u8 gu8FlushedAuthType; u32 gu32FlushedJoinReqSize; u32 gu32FlushedInfoElemAsocSize; @@ -1088,7 +1088,7 @@ static s32 Handle_Connect(struct host_if_drv *hif_drv, u32WidsCount++; if (memcmp("DIRECT-", pstrHostIFconnectAttr->ssid, 7)) - gu8Flushed11iMode = hif_drv->strWILC_UsrConnReq.u8security; + mode_11i = hif_drv->strWILC_UsrConnReq.u8security; PRINT_INFO(HOSTINF_DBG, "Encrypt Mode = %x\n", hif_drv->strWILC_UsrConnReq.u8security); @@ -1309,7 +1309,7 @@ static s32 Handle_FlushConnect(struct host_if_drv *hif_drv) strWIDList[u32WidsCount].id = (u16)WID_11I_MODE; strWIDList[u32WidsCount].type = WID_CHAR; strWIDList[u32WidsCount].size = sizeof(char); - strWIDList[u32WidsCount].val = (s8 *)(&(gu8Flushed11iMode)); + strWIDList[u32WidsCount].val = (s8 *)(&(mode_11i)); u32WidsCount++; -- 1.9.1 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel