From: Leo Kim <leo.kim@xxxxxxxxx> This patch renames variable gu32FlushedJoinReqSize to join_req_size to avoid CamelCase naming convention. Add to static because follow warning reported by kbuild system. - drivers/staging/wilc1000/host_interface.c:268:5: sparse: symbol 'join_req_size' was not declared. Should it be static? Signed-off-by: Leo Kim <leo.kim@xxxxxxxxx> Signed-off-by: Tony Cho <tony.cho@xxxxxxxxx> --- drivers/staging/wilc1000/host_interface.c | 10 +++++----- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wilc1000/host_interface.c index f06280b..f41a365 100644 --- a/drivers/staging/wilc1000/host_interface.c +++ b/drivers/staging/wilc1000/host_interface.c @@ -265,7 +265,7 @@ static u8 *join_req; static u8 *info_element; static u8 mode_11i; static u8 auth_type; -u32 gu32FlushedJoinReqSize; +static u32 join_req_size; u32 gu32FlushedInfoElemAsocSize; struct host_if_drv *gu8FlushedJoinReqDrvHandler; #define REAL_JOIN_REQ 0 @@ -1112,8 +1112,8 @@ static s32 Handle_Connect(struct host_if_drv *hif_drv, strWIDList[u32WidsCount].val = kmalloc(strWIDList[u32WidsCount].size, GFP_KERNEL); if (memcmp("DIRECT-", pstrHostIFconnectAttr->ssid, 7)) { - gu32FlushedJoinReqSize = strWIDList[u32WidsCount].size; - join_req = kmalloc(gu32FlushedJoinReqSize, GFP_KERNEL); + join_req_size = strWIDList[u32WidsCount].size; + join_req = kmalloc(join_req_size, GFP_KERNEL); } if (strWIDList[u32WidsCount].val == NULL) { s32Error = -EFAULT; @@ -1210,7 +1210,7 @@ static s32 Handle_Connect(struct host_if_drv *hif_drv, u32WidsCount++; if (memcmp("DIRECT-", pstrHostIFconnectAttr->ssid, 7)) { - memcpy(join_req, pu8CurrByte, gu32FlushedJoinReqSize); + memcpy(join_req, pu8CurrByte, join_req_size); gu8FlushedJoinReqDrvHandler = hif_drv; } @@ -1322,7 +1322,7 @@ static s32 Handle_FlushConnect(struct host_if_drv *hif_drv) strWIDList[u32WidsCount].id = (u16)WID_JOIN_REQ_EXTENDED; strWIDList[u32WidsCount].type = WID_STR; - strWIDList[u32WidsCount].size = gu32FlushedJoinReqSize; + strWIDList[u32WidsCount].size = join_req_size; strWIDList[u32WidsCount].val = (s8 *)join_req; pu8CurrByte = strWIDList[u32WidsCount].val; -- 1.9.1 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel