From: Leo Kim <leo.kim@xxxxxxxxx> This patch removes typedef from the struct tstrHostIFwepAttr. And rename it to host_if_wep_attr. Signed-off-by: Leo Kim <leo.kim@xxxxxxxxx> Signed-off-by: Tony Cho <tony.cho@xxxxxxxxx> --- drivers/staging/wilc1000/host_interface.c | 9 ++++----- 1 file changed, 4 insertions(+), 5 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wilc1000/host_interface.c index f4c5ec3..87866c4 100644 --- a/drivers/staging/wilc1000/host_interface.c +++ b/drivers/staging/wilc1000/host_interface.c @@ -97,7 +97,7 @@ typedef struct _tstrHostIFwpaAttr { /*! - * @struct tstrHostIFwepAttr + * @struct host_if_wep_attr * @brief Structure to hold Host IF Scan Attributes * @details * @todo @@ -106,14 +106,13 @@ typedef struct _tstrHostIFwpaAttr { * @date 25 March 2012 * @version 1.0 */ -typedef struct _tstrHostIFwepAttr { +struct host_if_wep_attr { u8 *pu8WepKey; u8 u8WepKeylen; u8 u8Wepidx; u8 u8mode; enum AUTHTYPE tenuAuth_type; - -} tstrHostIFwepAttr; +}; /*! * @struct host_if_key_attr @@ -126,7 +125,7 @@ typedef struct _tstrHostIFwepAttr { * @version 1.0 */ union host_if_key_attr { - tstrHostIFwepAttr strHostIFwepAttr; + struct host_if_wep_attr strHostIFwepAttr; tstrHostIFwpaAttr strHostIFwpaAttr; tstrHostIFpmkidAttr strHostIFpmkidAttr; }; -- 1.9.1 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel