From: Leo Kim <leo.kim@xxxxxxxxx> This patch remove typedef from the union tuniHostIFkeyAttr. And rename it to host_if_key_attr. Signed-off-by: Leo Kim <leo.kim@xxxxxxxxx> Signed-off-by: Tony Cho <tony.cho@xxxxxxxxx> --- drivers/staging/wilc1000/host_interface.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wilc1000/host_interface.c index 2e71505..f4c5ec3 100644 --- a/drivers/staging/wilc1000/host_interface.c +++ b/drivers/staging/wilc1000/host_interface.c @@ -116,7 +116,7 @@ typedef struct _tstrHostIFwepAttr { } tstrHostIFwepAttr; /*! - * @struct tuniHostIFkeyAttr + * @struct host_if_key_attr * @brief Structure to hold Host IF Scan Attributes * @details * @todo @@ -125,11 +125,11 @@ typedef struct _tstrHostIFwepAttr { * @date 25 March 2012 * @version 1.0 */ -typedef union _tuniHostIFkeyAttr { +union host_if_key_attr { tstrHostIFwepAttr strHostIFwepAttr; tstrHostIFwpaAttr strHostIFwpaAttr; tstrHostIFpmkidAttr strHostIFpmkidAttr; -} tuniHostIFkeyAttr; +}; /*! * @struct key_attr @@ -144,7 +144,7 @@ typedef union _tuniHostIFkeyAttr { struct key_attr { enum KEY_TYPE enuKeyType; u8 u8KeyAction; - tuniHostIFkeyAttr uniHostIFkeyAttr; + union host_if_key_attr uniHostIFkeyAttr; }; -- 1.9.1 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel