On Fri, Jul 31, 2015 at 12:27:04PM +0900, tony.cho wrote: > > > On 2015년 07월 30일 20:56, Sudip Mukherjee wrote: > >On Thu, Jul 30, 2015 at 06:10:10PM +0900, Tony Cho wrote: > >>This patch lets preprocessor conditionals (#ifdef) related to > >>WILC_SDIO_IRQ_GPIO to compile out the entire functions. Compiling out > >>the entire functions is preferred rather than portions of functions or > >>expressions becausue doing so makes code harder to read. > >> > >>Signed-off-by: Tony Cho <tony.cho@xxxxxxxxx> > >>--- > ><snip> > >>+#ifdef WILC_SDIO_IRQ_GPIO > >> static int sdio_clear_int(void) > >> { > >>-#ifndef WILC_SDIO_IRQ_GPIO > >>- /* uint32_t sts; */ > >>- sdio_cmd52_t cmd; > >>- > >>- cmd.read_write = 0; > >>- cmd.function = 1; > >>- cmd.raw = 0; > >>- cmd.address = 0x4; > >>- cmd.data = 0; > >>- g_sdio.sdio_cmd52(&cmd); > >>- int_clrd++; > >>- > >>- return cmd.data; > >>-#else > >> uint32_t reg; > >> if (!sdio_read_reg(WILC_HOST_RX_CTRL_0, ®)) { > >>@@ -181,9 +168,23 @@ static int sdio_clear_int(void) > >> sdio_write_reg(WILC_HOST_RX_CTRL_0, reg); > >> int_clrd++; > >> return 1; > >>-#endif > >>+} > >>+#else > >>+static int sdio_clear_int(void) > >>+{ > >>+ sdio_cmd52_t cmd; > >>+ > >>+ cmd.read_write = 0; > >>+ cmd.function = 1; > >>+ cmd.raw = 0; > >>+ cmd.address = 0x4; > >>+ cmd.data = 0; > >>+ g_sdio.sdio_cmd52(&cmd); > >>+ int_clrd++; > >>+ return cmd.data; > >> } > >>+#endif /* WILC_SDIO_IRQ_GPIO */ > >instead of changing #ifndef to #ifdef i think the following would have > >been easier: > > Yes, I agree with you. Great! > I will rewrite them after important patches are accepted. This is the first patch in the series, I'm not going to take it if you are going to redo it later, please fix it correctly. I'll drop this series from my queue. thanks, greg k-h _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel