Re: [PATCH v1 2/6] staging: qlge: coredump via devlink health reporter

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sat, Oct 10, 2020 at 10:22:30PM +0900, Benjamin Poirier wrote:
On 2020-10-10 18:02 +0800, Coiby Xu wrote:
[...]
> > +	do {                                                           \
> > +		err = fill_seg_(fmsg, &dump->seg_hdr, dump->seg_regs); \
> > +		if (err) {					       \
> > +			kvfree(dump);                                  \
> > +			return err;				       \
> > +		}                                                      \
> > +	} while (0)
> > +
> > +static int qlge_reporter_coredump(struct devlink_health_reporter *reporter,
> > +				  struct devlink_fmsg *fmsg, void *priv_ctx,
> > +				  struct netlink_ext_ack *extack)
> > +{
> > +	int err = 0;
> > +
> > +	struct qlge_devlink *dev = devlink_health_reporter_priv(reporter);
>
> Please name this variable ql_devlink, like in qlge_probe().

I happened to find the following text in drivers/staging/qlge/TODO
> * in terms of namespace, the driver uses either qlge_, ql_ (used by
>  other qlogic drivers, with clashes, ex: ql_sem_spinlock) or nothing (with
>  clashes, ex: struct ob_mac_iocb_req). Rename everything to use the "qlge_"
>  prefix.

This comment applies to global identifiers, not local variables.

Thank you for the explanation! Are you suggesting we should choose
different naming styles so we better tell global identifiers from local
variables?


So I will adopt qlge_ instead. Besides I prefer qlge_dl to ql_devlink.

Up to you but personally, I think ql_devlink is better. In any case,
"dev" is too general and often used for struct net_device pointers
instead.

Thank you for the suggestion. Another reason to use qlge_dl is many
other network drivers supporting devlink interface also adopt this kind
of style.

--
Best regards,
Coiby
_______________________________________________
devel mailing list
devel@xxxxxxxxxxxxxxxxxxxxxx
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel



[Index of Archives]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux