On 2020-10-12 19:51 +0800, Coiby Xu wrote: > On Sat, Oct 10, 2020 at 10:22:30PM +0900, Benjamin Poirier wrote: > > On 2020-10-10 18:02 +0800, Coiby Xu wrote: > > [...] > > > > > + do { \ > > > > > + err = fill_seg_(fmsg, &dump->seg_hdr, dump->seg_regs); \ > > > > > + if (err) { \ > > > > > + kvfree(dump); \ > > > > > + return err; \ > > > > > + } \ > > > > > + } while (0) > > > > > + > > > > > +static int qlge_reporter_coredump(struct devlink_health_reporter *reporter, > > > > > + struct devlink_fmsg *fmsg, void *priv_ctx, > > > > > + struct netlink_ext_ack *extack) > > > > > +{ > > > > > + int err = 0; > > > > > + > > > > > + struct qlge_devlink *dev = devlink_health_reporter_priv(reporter); > > > > > > > > Please name this variable ql_devlink, like in qlge_probe(). > > > > > > I happened to find the following text in drivers/staging/qlge/TODO > > > > * in terms of namespace, the driver uses either qlge_, ql_ (used by > > > > other qlogic drivers, with clashes, ex: ql_sem_spinlock) or nothing (with > > > > clashes, ex: struct ob_mac_iocb_req). Rename everything to use the "qlge_" > > > > prefix. > > > > This comment applies to global identifiers, not local variables. > > Thank you for the explanation! Are you suggesting we should choose > different naming styles so we better tell global identifiers from local > variables? That's not the main purpose IMO. Using a consistent prefix for global identifiers (ex. "qlge_") is to avoid clashes (two drivers using the same name, as in the examples above). Strictly speaking, it is not a problem for symbols with internal linkage (ex. static functions) or type definitions in local header files but it makes the code clearer because it shows immediately that this identifier was defined in the driver. For local variables, the name is more a matter of personal taste I think but it should be consistent within the driver and with other users of the same api, where applicable. A prefix is not needed but the name is sometimes a simpler version of a type name which includes a prefix. > > > So I will adopt qlge_ instead. Besides I prefer qlge_dl to ql_devlink. > > > > Up to you but personally, I think ql_devlink is better. In any case, > > "dev" is too general and often used for struct net_device pointers > > instead. > > Thank you for the suggestion. Another reason to use qlge_dl is many > other network drivers supporting devlink interface also adopt this kind > of style. Sounds good. On second thought I regretted suggesting ql_devlink. While local variable don't need any prefix; if they do have one, better not mix qlge_ and ql_. _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel