On 3/29/11, Roland Vossen <rvossen@xxxxxxxxxxxx> wrote: >> I worry that you're focused way too much on the wrong things. The main >> thing this driver needs is to be more readable so it can get merged out >> from staging. That comment was specifically about trying to optimize calls to WARN_ON() for speed. I can't review the code right now because someone stole my laptop yesterday and I'm traveling so it's going to take a while to replace it. The code has been improved a lot. One thing which should probably be in the TODO list is replacing broadcom error codes with standard error codes. BRD_NOMEM => ENOMEM or whatever. These are defined in the util.h file. I also don't like the WL_ERROR macro. I don't like the W_REG() and R_REG() macros much either. The caller should state explicitly if the are reading a byte, short or int something like brd_readb(). It should be a function so it has type checking. The current code is just guessing based on the type of variable... It's asking for bugs. The TODO file talks about implementing other features. I don't have a say in this but I don't think that's needed to get moved out of staging. regards, dan carpenter _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/devel