On Thu, 6 Jun 2024 13:11:09 +0300 Andy Shevchenko <andy.shevchenko@xxxxxxxxx> wrote: > On Thu, Jun 06, 2024 at 10:53:08AM +0200, Marek Behún wrote: > > On Wed, 5 Jun 2024 22:00:20 +0300 > > Andy Shevchenko <andy.shevchenko@xxxxxxxxx> wrote: > > > > > > + irq_idx = omnia_int_to_gpio_idx[__bf_shf(OMNIA_INT_TRNG)]; > > > > + irq = gpiod_to_irq(gpiochip_get_desc(&mcu->gc, irq_idx)); > > > > + if (irq < 0) > > > > + return dev_err_probe(dev, irq, "Cannot get TRNG IRQ\n"); > > > > > > Okay, it's a bit more complicated than that. The gpiochip_get_desc() > > > shouldn't be used. Bart, what can you suggest to do here? Opencoding > > > it doesn't sound to me a (fully) correct approach in a long term. > > > > Note that I can't use gpiochip_request_own_desc(), nor any other > > function that calls gpio_request_commit() (like gpiod_get()), because > > that checks for gpiochip_line_is_valid(), and this returns false for > > the TRNG line, cause that line is not a GPIO line, but interrupt only > > line. > > > > That is why I used > > irq = irq_create_mapping(dev, mcu->gc.irq.domain, irq_idx); > > until v7, with no reference to gpio descriptors, since this line is not > > a GPIO line. > > > > We have discussed this back in April, in the thread > > https://lore.kernel.org/soc/20240418121116.22184-8-kabel@xxxxxxxxxx/ > > where we concluded that > > irq = gpiod_to_irq(gpiochip_get_desc(gc, irq_idx)); > > is better... > > That's fine to not use other APIs, the problem here is with reference counting > on the GPIO device. The API you could use is gpio_device_get_desc(). But you > need to have a GPIO device pointer somewhere in your driver being available. Rewriting to gpio_device_get_desc() is simple, since gpiochip_get_desc(gc, hwnum) is equivalent to gpio_device_get_desc(gc->gpiodev, hwnum) Obviously neither of these take care of reference counting. But what reference counting are you talking about? Is it the try_module_get(desc->gdev->owner) in gpiod_request()? Or are we talking only about the FLAG_REQUESTED flag on the descriptor flags? (This one should not be needed since the GPIO line cannot be requested, becuase it is not a valid GPIO line.) Since the line is not a valid GPIO line, I thought that we don't need to refcount in GPIO code. gpiod_to_irq() will call the gpiochip's .to_irq() method, which will call gpiochip_to_irq(), which will call irq_create_mapping() gpiod_to_irq() gpiochip_to_irq() irq_create_mapping() Then on gpiochip removal, the gpiochip_irqchip_remove() manually disposes all IRQ mappings with irq_dispose_mapping(). Marek