On Wed, 5 Jun 2024 22:00:20 +0300 Andy Shevchenko <andy.shevchenko@xxxxxxxxx> wrote: > > + irq_idx = omnia_int_to_gpio_idx[__bf_shf(OMNIA_INT_TRNG)]; > > + irq = gpiod_to_irq(gpiochip_get_desc(&mcu->gc, irq_idx)); > > + if (irq < 0) > > + return dev_err_probe(dev, irq, "Cannot get TRNG IRQ\n"); > > Okay, it's a bit more complicated than that. The gpiochip_get_desc() > shouldn't be used. Bart, what can you suggest to do here? Opencoding > it doesn't sound to me a (fully) correct approach in a long term. Note that I can't use gpiochip_request_own_desc(), nor any other function that calls gpio_request_commit() (like gpiod_get()), because that checks for gpiochip_line_is_valid(), and this returns false for the TRNG line, cause that line is not a GPIO line, but interrupt only line. That is why I used irq = irq_create_mapping(dev, mcu->gc.irq.domain, irq_idx); until v7, with no reference to gpio descriptors, since this line is not a GPIO line. We have discussed this back in April, in the thread https://lore.kernel.org/soc/20240418121116.22184-8-kabel@xxxxxxxxxx/ where we concluded that irq = gpiod_to_irq(gpiochip_get_desc(gc, irq_idx)); is better... Marek