Hello, this picks up Dario's work. Changes since RFC: - move driver into subdir - rename flexcan_main.c -> flexcan-core.c (mcp251xfd and tcan4x5x driver have the same naming scheme) - use copyright notice from flexcan.c in flexcan.h - add private flag support to set rx-fifo - remove drvinfo, the kernel will fall back to the default implementation Show available private flags: | $ sudo ethtool --show-priv-flags can0 | Private flags for can0: | rx-fifo: on Change private flag: | $ sudo ethtool --set-priv-flags can0 rx-fifo off | netlink error: Device or resource busy ...does not work if interface is up. Shut down interface and change "rx-fifo": | $ sudo ip link set dev can0 down | $ sudo ethtool --set-priv-flags can0 rx-fifo off | $ sudo ethtool --show-priv-flags can0 | Private flags for can0: | rx-fifo: off | | $ sudo ip link set dev can0 up | $ sudo ethtool --show-priv-flags can0 | Private flags for can0: | rx-fifo: off Is the name "rx-fifo" acceptable? Can you think of a better name? What about adding a new quirk to the driver, only if that quirk is that, it is allowed to change between rx-fifo and rx-mailbox mode? What to you think? regards, Marc