> The temptation was to call device_unregister() which is a combined > device_del(); device_put(); but when the device_initialize() and > device_add() are called separately, then I think it is more readable to > call del and put separately as well. I think we should also consolidate the initialization side. Using device_register and device_unregister would have prevented this bug and I should have switched to that before refactoring the code.