On Thu, Oct 14, 2021 at 09:30:57AM -0600, Jens Axboe wrote: > > Can we turn this into a normal for loop? > > > > for (req = rq_list_peek(&iob->req_list); req; req = rq_list_next(req)) { > > .. > > } > > If you prefer it that way for nvme, for me the while () setup is much > easier to read than a really long for line. I prefer the loop over the while loop. My real preference would be a helper macro and do: for_each_rq(req, &iob->req_list) { as suggested last round.