Linux Arch
[Prev Page][Next Page]
- [PATCH v6 15/41] x86/mm: Update ptep/pmdp_set_wrprotect() for _PAGE_SAVED_DIRTY, (continued)
- [PATCH v6 15/41] x86/mm: Update ptep/pmdp_set_wrprotect() for _PAGE_SAVED_DIRTY, Rick Edgecombe
- [PATCH v6 16/41] x86/mm: Start actually marking _PAGE_SAVED_DIRTY, Rick Edgecombe
- [PATCH v6 17/41] mm: Move VM_UFFD_MINOR_BIT from 37 to 38, Rick Edgecombe
- [PATCH v6 20/41] x86/mm: Teach pte_mkwrite() about stack memory, Rick Edgecombe
- [PATCH v6 18/41] mm: Introduce VM_SHADOW_STACK for shadow stack memory, Rick Edgecombe
- [PATCH v6 19/41] x86/mm: Check shadow stack page fault errors, Rick Edgecombe
- [PATCH v6 21/41] mm: Add guard pages around a shadow stack., Rick Edgecombe
- [PATCH v6 22/41] mm/mmap: Add shadow stack pages to memory accounting, Rick Edgecombe
- [PATCH v6 23/41] mm: Re-introduce vm_flags to do_mmap(), Rick Edgecombe
- [PATCH v6 24/41] mm: Don't allow write GUPs to shadow stack memory, Rick Edgecombe
- [PATCH v6 25/41] x86/mm: Introduce MAP_ABOVE4G, Rick Edgecombe
- [PATCH v6 26/41] mm: Warn on shadow stack memory in wrong vma, Rick Edgecombe
- [PATCH v6 27/41] x86/mm: Warn if create Write=0,Dirty=1 with raw prot, Rick Edgecombe
- [PATCH v6 28/41] x86: Introduce userspace API for shadow stack, Rick Edgecombe
- [PATCH v6 29/41] x86/shstk: Add user-mode shadow stack support, Rick Edgecombe
- [PATCH v6 32/41] x86/shstk: Handle signals for shadow stack, Rick Edgecombe
- [PATCH v6 33/41] x86/shstk: Introduce map_shadow_stack syscall, Rick Edgecombe
- [PATCH v6 31/41] x86/shstk: Introduce routines modifying shstk, Rick Edgecombe
- [PATCH v6 30/41] x86/shstk: Handle thread shadow stack, Rick Edgecombe
- [PATCH v6 35/41] x86: Expose thread features in /proc/$PID/status, Rick Edgecombe
- [PATCH v6 36/41] x86/shstk: Wire in shadow stack interface, Rick Edgecombe
- [PATCH v6 34/41] x86/shstk: Support WRSS for userspace, Rick Edgecombe
- [PATCH v6 37/41] selftests/x86: Add shadow stack test, Rick Edgecombe
- [PATCH v6 39/41] x86: Add PTRACE interface for shadow stack, Rick Edgecombe
- [PATCH v6 40/41] x86/shstk: Add ARCH_SHSTK_UNLOCK, Rick Edgecombe
- [PATCH v6 38/41] x86/fpu: Add helper for initing features, Rick Edgecombe
- [PATCH v6 41/41] x86/shstk: Add ARCH_SHSTK_STATUS, Rick Edgecombe
- Re: [PATCH v6 00/41] Shadow stacks for userspace, Kees Cook
- Re: [PATCH v6 00/41] Shadow stacks for userspace, Mike Rapoport
- Re: [PATCH v6 00/41] Shadow stacks for userspace, John Allen
- Re: [PATCH v6 00/41] Shadow stacks for userspace, Pengfei Xu
- Re: [PATCH v6 00/41] Shadow stacks for userspace, Borislav Petkov
- [RFC PATCH 0/2] Add flag as THP allocation hint for memfd_restricted() syscall,
Ackerley Tng
- [PATCH 0/4] Remove #ifdef CONFIG_* from uapi headers (2023 edition),
Thomas Huth
- [GIT PULL] asm-generic: cleanups for 6.3,
Arnd Bergmann
- [linux-next:master] BUILD REGRESSION c068f40300a0eaa34f7105d137a5560b86951aa9, kernel test robot
- [PATCH v4 04/16] mm: ioremap: allow ARCH to have its own ioremap method definition,
Baoquan He
- [RFC PATCH 0/2] Providing mount for memfd_restricted() syscall,
Ackerley Tng
- [arnd-asm-generic:asm-generic] BUILD SUCCESS a13408c205260716e925a734ef399899d69182ba, kernel test robot
- [PATCH] dma-mapping: no need to pass a bus_type into get_arch_dma_ops(),
Greg Kroah-Hartman
- [PATCH v3 00/24] Remove COMMAND_LINE_SIZE from uapi,
Alexandre Ghiti
- [PATCH v3 01/24] alpha: Remove COMMAND_LINE_SIZE from uapi, Alexandre Ghiti
- [PATCH v3 02/24] arm64: Remove COMMAND_LINE_SIZE from uapi, Alexandre Ghiti
- [PATCH v3 03/24] arm: Remove COMMAND_LINE_SIZE from uapi, Alexandre Ghiti
- [PATCH v3 04/24] ia64: Remove COMMAND_LINE_SIZE from uapi, Alexandre Ghiti
- [PATCH v3 05/24] m68k: Remove COMMAND_LINE_SIZE from uapi, Alexandre Ghiti
- [PATCH v3 06/24] microblaze: Remove COMMAND_LINE_SIZE from uapi, Alexandre Ghiti
- [PATCH v3 07/24] mips: Remove COMMAND_LINE_SIZE from uapi, Alexandre Ghiti
- [PATCH v3 08/24] parisc: Remove COMMAND_LINE_SIZE from uapi, Alexandre Ghiti
- [PATCH v3 09/24] powerpc: Remove COMMAND_LINE_SIZE from uapi, Alexandre Ghiti
- [PATCH v3 10/24] sparc: Remove COMMAND_LINE_SIZE from uapi, Alexandre Ghiti
- [PATCH v3 11/24] xtensa: Remove COMMAND_LINE_SIZE from uapi, Alexandre Ghiti
- [PATCH v3 12/24] asm-generic: Remove COMMAND_LINE_SIZE from uapi, Alexandre Ghiti
- [PATCH v3 13/24] alpha: Remove empty <uapi/asm/setup.h>, Alexandre Ghiti
- [PATCH v3 14/24] arc: Remove empty <uapi/asm/setup.h>, Alexandre Ghiti
- [PATCH v3 15/24] m68k: Remove empty <uapi/asm/setup.h>, Alexandre Ghiti
- [PATCH v3 16/24] arm64: Remove empty <uapi/asm/setup.h>, Alexandre Ghiti
- [PATCH v3 17/24] microblaze: Remove empty <uapi/asm/setup.h>, Alexandre Ghiti
- [PATCH v3 18/24] sparc: Remove empty <uapi/asm/setup.h>, Alexandre Ghiti
- [PATCH v3 19/24] parisc: Remove empty <uapi/asm/setup.h>, Alexandre Ghiti
- [PATCH v3 20/24] x86: Remove empty <uapi/asm/setup.h>, Alexandre Ghiti
- [PATCH v3 21/24] xtensa: Remove empty <uapi/asm/setup.h>, Alexandre Ghiti
- [PATCH v3 22/24] powerpc: Remove empty <uapi/asm/setup.h>, Alexandre Ghiti
- [PATCH v3 23/24] mips: Remove empty <uapi/asm/setup.h>, Alexandre Ghiti
- [PATCH v3 24/24] s390: Remove empty <uapi/asm/setup.h>, Alexandre Ghiti
- Re: [PATCH v3 00/24] Remove COMMAND_LINE_SIZE from uapi, Heiko Carstens
- [PATCH v1 RFC Zisslpcfi 05/20] mmap : Introducing new protection "PROT_SHADOWSTACK" for mmap, Deepak Gupta
- [PATCH] tools/memory-model: Add details about SRCU read-side critical sections,
Joel Fernandes (Google)
- [PATCH 0/2] char/agp: consolidate asm/agp.h,
Mike Rapoport
- [PATCH 0/7] New arch interfaces for manipulating multiple pages,
Matthew Wilcox (Oracle)
- [PATCH 5.4 v2 0/6] Fix Build ID on arm64 if CONFIG_MODVERSIONS=y,
Tom Saeger
- [PATCH 5.10 v2 0/5] Fix Build ID on arm64 if CONFIG_MODVERSIONS=y,
Tom Saeger
- [PATCH 5.15 v2 0/5] Fix Build ID on arm64 if CONFIG_MODVERSIONS=y,
Tom Saeger
- [PATCH 6.1 v2 0/7] Backport Build ID fixes,
Tom Saeger
- [PATCH v4 00/18] gpiolib cleanups,
Andy Shevchenko
- [PATCH v4 10/18] gpiolib: split linux/gpio/driver.h out of linux/gpio.h, Andy Shevchenko
- [PATCH v4 09/18] gpiolib: remove legacy gpio_export(), Andy Shevchenko
- [PATCH v4 15/18] gpiolib: Drop unused forward declaration from driver.h, Andy Shevchenko
- [PATCH v4 01/18] ARM: orion/gpio: Use the right include, Andy Shevchenko
- [PATCH v4 16/18] gpiolib: Deduplicate forward declarations in consumer.h, Andy Shevchenko
- [PATCH v4 07/18] gpiolib: remove asm-generic/gpio.h, Andy Shevchenko
- [PATCH v4 02/18] ARM: s3c24xx: Use the right include, Andy Shevchenko
- [PATCH v4 03/18] hte: tegra-194: Use proper includes, Andy Shevchenko
- [PATCH v4 05/18] gpiolib: remove empty asm/gpio.h files, Andy Shevchenko
- [PATCH v4 04/18] gpiolib: Make the legacy <linux/gpio.h> consumer-only, Andy Shevchenko
- [PATCH v4 08/18] gpiolib: remove gpio_set_debounce(), Andy Shevchenko
- [PATCH v4 06/18] gpiolib: coldfire: remove custom asm/gpio.h, Andy Shevchenko
- [PATCH v4 11/18] gpiolib: split of_mm_gpio_chip out of linux/of_gpio.h, Andy Shevchenko
- [PATCH v4 12/18] gpio: aggregator: Add missing header(s), Andy Shevchenko
- [PATCH v4 13/18] gpio: reg: Add missing header(s), Andy Shevchenko
- [PATCH v4 14/18] gpio: regmap: Add missing header(s), Andy Shevchenko
- [PATCH v4 17/18] gpiolib: Group forward declarations in consumer.h, Andy Shevchenko
- [PATCH v4 18/18] gpiolib: Clean up headers, Andy Shevchenko
- Re: [PATCH v4 00/18] gpiolib cleanups, Bartosz Golaszewski
- [PATCH V2] LoongArch: Make -mstrict-align configurable,
Huacai Chen
- [PATCH v3 00/12] gpiolib cleanups,
Andy Shevchenko
- [PATCH v3 06/12] gpiolib: split linux/gpio/driver.h out of linux/gpio.h, Andy Shevchenko
- [PATCH v3 02/12] gpiolib: coldfire: remove custom asm/gpio.h, Andy Shevchenko
- [PATCH v3 03/12] gpiolib: remove asm-generic/gpio.h, Andy Shevchenko
- [PATCH v3 05/12] gpiolib: remove legacy gpio_export, Andy Shevchenko
- [PATCH v3 01/12] gpiolib: remove empty asm/gpio.h files, Andy Shevchenko
- [PATCH v3 11/12] gpiolib: Group forward declarations in consumer.h, Andy Shevchenko
- [PATCH v3 07/12] gpiolib: split of_mm_gpio_chip out of linux/of_gpio.h, Andy Shevchenko
- [PATCH v3 10/12] gpiolib: Deduplicate forward declarations in consumer.h, Andy Shevchenko
- [PATCH v3 04/12] gpiolib: remove gpio_set_debounce, Andy Shevchenko
- [PATCH v3 12/12] gpiolib: Clean up headers, Andy Shevchenko
- [PATCH v3 08/12] gpio: aggregator: Add missing header(s), Andy Shevchenko
- [PATCH v3 09/12] gpiolib: Drop unused forward declaration from driver.h, Andy Shevchenko
- [PATCH v3 0/6] Support TDX guests on Hyper-V,
Dexuan Cui
- [syzbot] kernel BUG in process_one_work,
syzbot
- [PATCH] riscv: Cleanup rv32_defconfig,
guoren
- [syzbot] kernel BUG in __tlb_remove_page_size (2),
syzbot
- [PATCH -next V16 0/7] riscv: Add GENERIC_ENTRY support,
guoren
- [PATCH V2] riscv: kprobe: Fixup misaligned load text,
guoren
- Current LKMM patch disposition,
Paul E. McKenney
- [PATCH RFC] tools/memory-model: Restrict to-r to read-read address dependency,
Joel Fernandes (Google)
- [RFC PATCH 00/32] ACPI/arm64: add support for virtual cpuhotplug,
James Morse
- [RFC PATCH 01/32] ia64: Fix build error due to switch case label appearing next to declaration, James Morse
- [RFC PATCH 02/32] ACPI: Move ACPI_HOTPLUG_CPU to be enabled per architecture, James Morse
- [RFC PATCH 06/32] arm64: setup: Switch over to GENERIC_CPU_DEVICES using arch_register_cpu(), James Morse
- [RFC PATCH 05/32] drivers: base: Move cpu_dev_init() after node_dev_init(), James Morse
- [RFC PATCH 04/32] drivers: base: Allow parts of GENERIC_CPU_DEVICES to be overridden, James Morse
- [RFC PATCH 03/32] drivers: base: Use present CPUs in GENERIC_CPU_DEVICES, James Morse
- [RFC PATCH 07/32] ia64/topology: Switch over to GENERIC_CPU_DEVICES, James Morse
- [RFC PATCH 09/32] LoongArch: Switch over to GENERIC_CPU_DEVICES, James Morse
- [RFC PATCH 10/32] arch_topology: Make register_cpu_capacity_sysctl() tolerant to late CPUs, James Morse
- [RFC PATCH 14/32] ACPI: Rename ACPI_HOTPLUG_CPU to include 'present', James Morse
- [RFC PATCH 08/32] x86/topology: Switch over to GENERIC_CPU_DEVICES, James Morse
- [RFC PATCH 11/32] ACPI: processor: Add support for processors described as container packages, James Morse
- [RFC PATCH 12/32] ACPI: processor: Register CPUs that are online, but not described in the DSDT, James Morse
- [RFC PATCH 17/32] ACPI: Add post_eject to struct acpi_scan_handler for cpu hotplug, James Morse
- [RFC PATCH 30/32] KVM: arm64: Pass PSCI calls to userspace, James Morse
- [RFC PATCH 16/32] ACPI: Rename acpi_processor_hotadd_init and remove pre-processor guards, James Morse
- [RFC PATCH 27/32] arm64: psci: Ignore DENIED CPUs, James Morse
- [RFC PATCH 20/32] drivers: base: Implement weak arch_unregister_cpu(), James Morse
- [RFC PATCH 15/32] ACPI: Move acpi_bus_trim_one() before acpi_scan_hot_remove(), James Morse
- [RFC PATCH 13/32] ACPI: processor: Register all CPUs from acpi_processor_get_info(), James Morse
- [RFC PATCH 31/32] arm64: document virtual CPU hotplug's expectations, James Morse
- [RFC PATCH 21/32] LoongArch: Use the __weak version of arch_unregister_cpu(), James Morse
- [RFC PATCH 22/32] arm64: acpi: Move get_cpu_for_acpi_id() to a header, James Morse
- [RFC PATCH 29/32] KVM: arm64: Pass hypercalls to userspace, James Morse
- [RFC PATCH 24/32] arm64, irqchip/gic-v3, ACPI: Move MADT GICC enabled check into a helper, James Morse
- [RFC PATCH 25/32] irqchip/gic-v3: Don't return errors from gic_acpi_match_gicc(), James Morse
- [RFC PATCH 18/32] ACPI: Check _STA present bit before making CPUs not present, James Morse
- [RFC PATCH 26/32] irqchip/gic-v3: Add support for ACPI's disabled but 'online capable' CPUs, James Morse
- [RFC PATCH 19/32] ACPI: Warn when the present bit changes but the feature is not enabled, James Morse
- [RFC PATCH 23/32] ACPICA: Add new MADT GICC flags fields [code first?], James Morse
- [RFC PATCH 28/32] ACPI: add support to register CPUs based on the _STA enabled bit, James Morse
- [RFC PATCH 32/32] cpumask: Add enabled cpumask for present CPUs that can be brought online, James Morse
- Re: [RFC PATCH 00/32] ACPI/arm64: add support for virtual cpuhotplug, Jonathan Cameron
- Re: [RFC PATCH 00/32] ACPI/arm64: add support for virtual cpuhotplug, Gavin Shan
- Re: [RFC PATCH 00/32] ACPI/arm64: add support for virtual cpuhotplug, Shaoqin Huang
- [PATCH v7 0/5] shoot lazy tlbs (lazy tlb refcount scalability improvement),
Nicholas Piggin
- API for setting multiple PTEs at once,
Matthew Wilcox
- [PATCH v2 00/10] Introduce cmpxchg128() -- aka. the demise of cmpxchg_double(),
Peter Zijlstra
- [PATCH v2 04/10] instrumentation: Wire up cmpxchg128(), Peter Zijlstra
- [PATCH v2 01/10] cyrpto/b128ops: Remove struct u128, Peter Zijlstra
- [PATCH v2 05/10] percpu: Wire up cmpxchg128, Peter Zijlstra
- [PATCH v2 06/10] x86,amd_iommu: Replace cmpxchg_double(), Peter Zijlstra
- [PATCH v2 08/10] slub: Replace cmpxchg_double(), Peter Zijlstra
- [PATCH v2 03/10] arch: Introduce arch_{,try_}_cmpxchg128{,_local}(), Peter Zijlstra
- [PATCH v2 07/10] x86,intel_iommu: Replace cmpxchg_double(), Peter Zijlstra
- [PATCH v2 02/10] types: Introduce [us]128, Peter Zijlstra
- [PATCH v2 10/10] s390/cpum_sf: Convert to cmpxchg128(), Peter Zijlstra
- [PATCH v2 09/10] arch: Remove cmpxchg_double, Peter Zijlstra
- Re: [PATCH v2 00/10] Introduce cmpxchg128() -- aka. the demise of cmpxchg_double(), Linus Torvalds
- [PATCH] LoongArch: Make -mstrict-align be configurable,
Huacai Chen
- [PATCH] locking/atomic: cmpxchg: Make __generic_cmpxchg_local compare against zero-extended 'old' value,
Matt Evans
- [PATCH] riscv: kprobe: Fixup misaligned load text,
guoren
- [PATCH V2] riscv: kprobe: Fixup kernel panic when probing an illegal position,
guoren
- [RFC][PATCHSET] VM_FAULT_RETRY fixes,
Al Viro
- [PATCH 01/10] alpha: fix livelock in uaccess, Al Viro
- [PATCH 02/10] hexagon: fix livelock in uaccess, Al Viro
- [PATCH 03/10] ia64: fix livelock in uaccess, Al Viro
- [PATCH 04/10] m68k: fix livelock in uaccess, Al Viro
- [PATCH 05/10] microblaze: fix livelock in uaccess, Al Viro
- [PATCH 06/10] nios2: fix livelock in uaccess, Al Viro
- [PATCH 07/10] openrisc: fix livelock in uaccess, Al Viro
- [PATCH 08/10] parisc: fix livelock in uaccess, Al Viro
- [PATCH 09/10] riscv: fix livelock in uaccess, Al Viro
- [PATCH 10/10] sparc: fix livelock in uaccess, Al Viro
- Re: [RFC][PATCHSET] VM_FAULT_RETRY fixes, Linus Torvalds
- Re: [RFC][PATCHSET] VM_FAULT_RETRY fixes, Mark Rutland
- [PATCH] riscv: mm: fix regression due to update_mmu_cache change,
Sergey Matyukevich
- [PATCH memory-model] Add smp_mb__after_srcu_read_unlock(), Paul E. McKenney
- [PATCH v2 0/4] mm, arch: add generic implementation of pfn_valid() for FLATMEM,
Mike Rapoport
- Re: [PATCH] sh: define RUNTIME_DISCARD_EXIT, Tom Saeger
- [PATCH 15/35] Documentation: litmus-tests: correct spelling,
Randy Dunlap
[PATCH] locking/atomic: atomic: Use arch_atomic_{read,set} in generic atomic ops,
Jules Maselbas
[PATCH -next V15 0/7] riscv: Add GENERIC_ENTRY support,
guoren
[PATCH resend] iopoll: Call cpu_relax() in busy loops,
Geert Uytterhoeven
KASAN: slab-out-of-bounds Read in ntfs_test_inode, Sanan Hasanov
[PATCH v2] nvdimm: Support sizeof(struct page) > MAX_STRUCT_PAGE_SIZE,
Dan Williams
[PATCH v1 0/5] gpio: First attempt to clean up headers,
Andy Shevchenko
[Index of Archives]
[Kernel Announce]
[Kernel Newbies]
[Linux RAID]
[IETF Annouce]
[Security]
[Netdev]
[Linux Wireless]
[Netfilter]
[Bugtraq]