On Sat, May 9, 2020 at 7:36 PM Syed Nayyar Waris <syednwaris@xxxxxxxxx> wrote: > On Tue, May 5, 2020 at 8:24 PM William Breathitt Gray > <vilhelm.gray@xxxxxxxxx> wrote: > > On Tue, May 05, 2020 at 04:51:56PM +0300, Andy Shevchenko wrote: > > > On Mon, May 4, 2020 at 5:41 PM William Breathitt Gray > > > <vilhelm.gray@xxxxxxxxx> wrote: > > > > On Mon, May 04, 2020 at 02:41:09PM +0300, Andy Shevchenko wrote: > > > > > On Sun, May 03, 2020 at 04:38:36AM +0530, Syed Nayyar Waris wrote: ... > > > > > Looking into the last patches where we have examples I still do not see a > > > > > benefit of variadic clump sizes. power of 2 sizes would make sense (and be > > > > > optimized accordingly (64-bit, 32-bit). > > > > There is of course benefit in defining for_each_set_clump with clump > > > > sizes of powers of 2 (we can optimize for 32 and 64 bit sizes and avoid > > > > boundary checks that we know will not occur), but at the very least the > > > > variable size bitmap_set_value and bitmap_get_value provide significant > > > > benefit for the readability of the gpio-xilinx code: > > > > > > > > bitmap_set_value(old, state[0], 0, width[0]); > > > > bitmap_set_value(old, state[1], width[0], width[1]); > > > > ... > > > > state[0] = bitmap_get_value(new, 0, width[0]); > > > > state[1] = bitmap_get_value(new, width[0], width[1]); > > > > > > > > These lines are simple and clear to read: we know immediately what they > > > > do. But if we did not have bitmap_set_value/bitmap_get_value, we'd have > > > > to use several bitwise operations for each line; the obfuscation of the > > > > code would be an obvious hinderance here. > > > > > > Do I understand correctly that width[0] and width[1] may not be power > > > of two and it's actually the case? > > I'm under the impression that width[0] and width[1] are arbitrarily > > chosen by the user and could be any integer. I have never used this > > hardware so I'm hoping one of the gpio-xilinx or GPIO subsystem > > maintainers in this thread will respond with some guidance. > > > > If the values of width[0] and width[1] are restricted to powers of 2, > > then I agree that there is no need for generic bitmap_set_value and > > bitmap_get_value functions and we can instead use more optimized power > > of 2 versions. > Regarding the question that whether width[0] and width[1] can have any > value or they are restricted to power-of-2. > > Referring to the document (This xilinx GPIO IP was mentioned in the > gpio-xilinx.c file): > https://www.xilinx.com/support/documentation/ip_documentation/axi_gpio/v2_0/pg144-axi-gpio.pdf > > On page 8, we can see that the GPIO widths for the 2 channels can have > values different from power-of-2.For example: 5, 15 etc. > > So, I think we should keep the 'for_each_set_clump', > 'bitmap_get_value' and 'bitmap_set_value' as completely generic. > > I am proceeding further for my next patchset submission keeping above > findings in mind. If you guys think something else or would like to > add something, let me know. Thank you for investigation. So, if Xilinx is okay with the change, I have no objections. -- With Best Regards, Andy Shevchenko