On Mon, May 4, 2020 at 5:41 PM William Breathitt Gray <vilhelm.gray@xxxxxxxxx> wrote: > On Mon, May 04, 2020 at 02:41:09PM +0300, Andy Shevchenko wrote: > > On Sun, May 03, 2020 at 04:38:36AM +0530, Syed Nayyar Waris wrote: ... > > Looking into the last patches where we have examples I still do not see a > > benefit of variadic clump sizes. power of 2 sizes would make sense (and be > > optimized accordingly (64-bit, 32-bit). > > > > -- > > With Best Regards, > > Andy Shevchenko > > There is of course benefit in defining for_each_set_clump with clump > sizes of powers of 2 (we can optimize for 32 and 64 bit sizes and avoid > boundary checks that we know will not occur), but at the very least the > variable size bitmap_set_value and bitmap_get_value provide significant > benefit for the readability of the gpio-xilinx code: > > bitmap_set_value(old, state[0], 0, width[0]); > bitmap_set_value(old, state[1], width[0], width[1]); > ... > state[0] = bitmap_get_value(new, 0, width[0]); > state[1] = bitmap_get_value(new, width[0], width[1]); > > These lines are simple and clear to read: we know immediately what they > do. But if we did not have bitmap_set_value/bitmap_get_value, we'd have > to use several bitwise operations for each line; the obfuscation of the > code would be an obvious hinderance here. Do I understand correctly that width[0] and width[1] may not be power of two and it's actually the case? -- With Best Regards, Andy Shevchenko