On Fri, 26 Aug 2016 15:22:19 +0200 "Luis R. Rodriguez" <mcgrof@xxxxxxxxxx> wrote: > On Fri, Aug 26, 2016 at 05:33:38PM +1000, Nicholas Piggin wrote: > > On Thu, 25 Aug 2016 23:38:44 -0700 > > "Luis R. Rodriguez" <mcgrof@xxxxxxxxxx> wrote: > > > > > > > Ah, thing is we use this for both linktables and section ranges. > > > > > > > Or do we want macros for both that do the same thing ? > > > > > > > > > > > > I think it would make the code using it more readable. > > > > > > > > > > Alrighty... so: > > > > > > > > > > LINKTABLE_START() > > > > > LINKTABLE_END() > > > > > > > > > > SECTION_RANGE_START() > > > > > SECTION_RANGE_END() > > > > > > > > > > And these macros do the exact same thing. Ie, nothing shared. Right? > > > > > > > > Yeah I think so. Internally they would probably be aliased to the > > > > same common definition (unless you had some type check or something), > > > > but user would know about such details. > > > > > > What name should we use for such common macro definition ? > > > > > > Ah, not really sure. I guess the "link table" is some kind of > > section range? I haven't actually looked closely at both of them > > in the subsequent patches. It matters less if it's not expected > > to be used as an API though. > > > > OK well, going with LINUX_SECTION_START() so we'll have: > > #define LINKTABLE_START LINUX_SECTION_START > #define LINKTABLE_END LINUX_SECTION_END > > #define SECTION_RANGE_START LINUX_SECTION_START > #define SECTION_RANGE_END LINUX_SECTION_END > > Is that OK? I guess so, without having seen the updated, although I don't see why you'd not just #define LINKTABLE_START SECTION_RANGE_START -- To unsubscribe from this list: send the line "unsubscribe linux-arch" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html