On Mon, Mar 03, 2025 at 06:00:33PM +0200, Andy Shevchenko wrote: > In order to reduce the 'gpio' namespace when operate over GPIO descriptor > rename gpio_set_debounce_timeout() to gpiod_do_set_debounce(). To me anything that has '_do_' in their name sounds like an internal static function that gets wrapped by the actual API function(s). For instance it could be int gpio_set_debounce_timeout() { ... gpiod_do_set_debounce() ... However, gpiod_set_debounce_timeout() or gpiod_set_debounce() sounds good to me.