In order to reduce the 'gpio' namespace when operate over GPIO descriptor rename a couple of functions. The choice of the name in patch 2 is inspired by the existing gpio_do_set_config() versus gpiod_set_config(). The patch 3 also fixes it to be gpiod_do_set_config(), so we establish two namespaces here: - gpiod_do_foo() for the internal APIs - gpiod_foo() for the external APIs for whatever foo that makes sense. While at it, the ad-hoc amendment to the FLAG_* definitions to increase readability. No functional changes intended nor made. Andy Shevchenko (3): gpiolib: Align FLAG_* definitions in the struct gpio_desc gpiolib: Rename gpio_set_debounce_timeout() to gpiod_do_set_debounce() gpiolib: Rename gpio_do_set_config() --> gpiod_do_set_config() drivers/gpio/gpiolib-acpi.c | 4 ++-- drivers/gpio/gpiolib-cdev.c | 2 +- drivers/gpio/gpiolib.c | 10 +++++----- drivers/gpio/gpiolib.h | 40 ++++++++++++++++++------------------- 4 files changed, 28 insertions(+), 28 deletions(-) -- 2.47.2