On Tue, Oct 17, 2023 at 09:58:08AM -0700, Raghavendra Rao Ananta wrote: > On Mon, Oct 16, 2023 at 10:52 PM Oliver Upton <oliver.upton@xxxxxxxxx> wrote: > > > > On Mon, Oct 16, 2023 at 02:35:52PM -0700, Raghavendra Rao Ananta wrote: > > > > [...] > > > > > > What's the point of doing this in the first place? The implementation of > > > > kvm_vcpu_read_pmcr() is populating PMCR_EL0.N using the VM-scoped value. > > > > > > > I guess originally the change replaced read_sysreg(pmcr_el0) with > > > kvm_vcpu_read_pmcr(vcpu) to maintain consistency with others. > > > But if you and Sebastian feel that it's an overkill and directly > > > getting the value via vcpu->kvm->arch.pmcr_n is more readable, I'm > > > happy to make the change. > > > > No, I'd rather you delete the line where PMCR_EL0.N altogether. > > reset_pmcr() tries to initialize the field, but your > > kvm_vcpu_read_pmcr() winds up replacing it with pmcr_n. > > > I didn't get this comment. We still do initialize pmcr, but using the > pmcr.n read via kvm_vcpu_read_pmcr() instead of the actual system > register. You have two bits of code trying to do the exact same thing: 1) reset_pmcr() initializes __vcpu_sys_reg(vcpu, PMCR_EL0) with the N field set up. 2) kvm_vcpu_read_pmcr() takes whatever is in __vcpu_sys_reg(vcpu, PMCR_EL0), *masks out* the N field and re-initializes it with vcpu->kvm->arch.pmcr_n Why do you need (1) if you do (2)? -- Thanks, Oliver