On Mon, Oct 16, 2023 at 12:16 PM Oliver Upton <oliver.upton@xxxxxxxxx> wrote: > > On Mon, Oct 16, 2023 at 12:02:27PM -0700, Raghavendra Rao Ananta wrote: > > On Mon, Oct 16, 2023 at 6:35 AM Sebastian Ott <sebott@xxxxxxxxxx> wrote: > > > > > > On Mon, 9 Oct 2023, Raghavendra Rao Ananta wrote: > > > > u64 kvm_vcpu_read_pmcr(struct kvm_vcpu *vcpu) > > > > { > > > > - return __vcpu_sys_reg(vcpu, PMCR_EL0); > > > > + u64 pmcr = __vcpu_sys_reg(vcpu, PMCR_EL0) & > > > > + ~(ARMV8_PMU_PMCR_N_MASK << ARMV8_PMU_PMCR_N_SHIFT); > > > > + > > > > + return pmcr | ((u64)vcpu->kvm->arch.pmcr_n << ARMV8_PMU_PMCR_N_SHIFT); > > > > } > > > > diff --git a/arch/arm64/kvm/sys_regs.c b/arch/arm64/kvm/sys_regs.c > > > > index ff0f7095eaca..c750722fbe4a 100644 > > > > --- a/arch/arm64/kvm/sys_regs.c > > > > +++ b/arch/arm64/kvm/sys_regs.c > > > > @@ -745,12 +745,8 @@ static u64 reset_pmcr(struct kvm_vcpu *vcpu, const struct sys_reg_desc *r) > > > > { > > > > u64 pmcr; > > > > > > > > - /* No PMU available, PMCR_EL0 may UNDEF... */ > > > > - if (!kvm_arm_support_pmu_v3()) > > > > - return 0; > > > > - > > > > /* Only preserve PMCR_EL0.N, and reset the rest to 0 */ > > > > - pmcr = read_sysreg(pmcr_el0) & (ARMV8_PMU_PMCR_N_MASK << ARMV8_PMU_PMCR_N_SHIFT); > > > > + pmcr = kvm_vcpu_read_pmcr(vcpu) & (ARMV8_PMU_PMCR_N_MASK << ARMV8_PMU_PMCR_N_SHIFT); > > > > > > pmcr = ((u64)vcpu->kvm->arch.pmcr_n << ARMV8_PMU_PMCR_N_SHIFT); > > > Would that maybe make it more clear what is done here? > > > > > Since we require the entire PMCR register, and not just the PMCR.N > > field, I think using kvm_vcpu_read_pmcr() would be technically > > correct, don't you think? > > No, this isn't using the entire PMCR value, it is just grabbing > PMCR_EL0.N. > Oh sorry, my bad. > What's the point of doing this in the first place? The implementation of > kvm_vcpu_read_pmcr() is populating PMCR_EL0.N using the VM-scoped value. > I guess originally the change replaced read_sysreg(pmcr_el0) with kvm_vcpu_read_pmcr(vcpu) to maintain consistency with others. But if you and Sebastian feel that it's an overkill and directly getting the value via vcpu->kvm->arch.pmcr_n is more readable, I'm happy to make the change. Thank you. Raghavendra > -- > Thanks, > Oliver