On Mon, Oct 16, 2023 at 02:35:52PM -0700, Raghavendra Rao Ananta wrote: [...] > > What's the point of doing this in the first place? The implementation of > > kvm_vcpu_read_pmcr() is populating PMCR_EL0.N using the VM-scoped value. > > > I guess originally the change replaced read_sysreg(pmcr_el0) with > kvm_vcpu_read_pmcr(vcpu) to maintain consistency with others. > But if you and Sebastian feel that it's an overkill and directly > getting the value via vcpu->kvm->arch.pmcr_n is more readable, I'm > happy to make the change. No, I'd rather you delete the line where PMCR_EL0.N altogether. reset_pmcr() tries to initialize the field, but your kvm_vcpu_read_pmcr() winds up replacing it with pmcr_n. > @@ -1105,8 +1109,16 @@ u8 kvm_arm_pmu_get_pmuver_limit(void) > /** > * kvm_vcpu_read_pmcr - Read PMCR_EL0 register for the vCPU > * @vcpu: The vcpu pointer > + * > + * The function returns the value of PMCR.N based on the per-VM tracked > + * value (kvm->arch.pmcr_n). This is to ensure that the register field > + * remains consistent for the VM, even on heterogeneous systems where > + * the value may vary when read from different CPUs (during vCPU reset). Since I'm looking at this again, I don't believe the comment is adding much. KVM doesn't read pmcr_el0 directly anymore, and kvm_arch is clearly VM-scoped context. > */ > u64 kvm_vcpu_read_pmcr(struct kvm_vcpu *vcpu) > { > - return __vcpu_sys_reg(vcpu, PMCR_EL0); > + u64 pmcr = __vcpu_sys_reg(vcpu, PMCR_EL0) & > + ~(ARMV8_PMU_PMCR_N_MASK << ARMV8_PMU_PMCR_N_SHIFT); > + > + return pmcr | ((u64)vcpu->kvm->arch.pmcr_n << ARMV8_PMU_PMCR_N_SHIFT); > } -- Thanks, Oliver