On 10/18/22 7:32 AM, Sean Christopherson wrote:
On Tue, Oct 18, 2022, Gavin Shan wrote:
On 10/18/22 6:56 AM, Maciej S. Szmigiero wrote:
On 18.10.2022 00:51, Gavin Shan wrote:
On 10/18/22 6:08 AM, Sean Christopherson wrote:
On Mon, Oct 17, 2022, Maciej S. Szmigiero wrote:
+#define MEM_EXTRA_SIZE 0x10000
Also, an expression like "(64 << 10)" is more readable than a "1"
with a tail of zeroes (it's easy to add one zero too many or be one
zero short).
+1 to not open coding raw numbers.
I think it's high time KVM selftests add #defines for the common sizes, e.g. SIZE_4KB,
16KB, 64K, 2MB, 1GB, etc...
Alternatively (or in addition), just #define 1KB, 1MB, 1GB, and 1TB, and then do
math off of those.
Ok. I will have one separate patch to define those sizes in kvm_util_base.h,
right after '#define NSEC_PER_SEC 1000000000L'. Sean, could you let me know
if it looks good to you?
#define KB (1UL << 10)
#define MB (1UL << 20)
#define GB (1UL << 30)
#define TB (1UL << 40)
Any objection to prefixing these with SIZE_ as well? IMO it's worth burning the
extra five characters to make it all but impossible to misinterpret code.
'SIZE_' prefix works for me either.
/* Base page and huge page size */
#define SIZE_4KB ( 4 * KB)
#define SIZE_16KB ( 16 * KB)
#define SIZE_64KB ( 64 * KB)
#define SIZE_2MB ( 2 * MB)
#define SIZE_32MB ( 32 * MB)
#define SIZE_512MB (512 * MB)
#define SIZE_1GB ( 1 * GB)
#define SIZE_16GB ( 16 * GB)
FYI, QEMU uses KiB, MiB, GiB, etc., see [1].
Right. I checked QEMU's definitions and it makes sense to use
KiB, MiB, GiB, TiB. I don't think we need PiB and EiB because
our tests don't use that large memory.
Ha! I had typed out KiB, etc... but then thought, "nah, I'm being silly". KiB
and friends work for me.
Thanks for your confirm, Sean.
Thanks,
Gavin