On Thu, Jan 06, 2022 at 02:20:25PM -0800, David Matlack wrote: > > > diff --git a/arch/x86/kvm/x86.c b/arch/x86/kvm/x86.c > > > index 85127b3e3690..fb5592bf2eee 100644 > > > --- a/arch/x86/kvm/x86.c > > > +++ b/arch/x86/kvm/x86.c > > > @@ -187,6 +187,9 @@ module_param(force_emulation_prefix, bool, S_IRUGO); > > > int __read_mostly pi_inject_timer = -1; > > > module_param(pi_inject_timer, bint, S_IRUGO | S_IWUSR); > > > > > > +static bool __read_mostly eagerly_split_huge_pages_for_dirty_logging = true; > > > +module_param(eagerly_split_huge_pages_for_dirty_logging, bool, 0644); > > > > Heh, can we use a shorter name for the module param? There's 0% chance I'll ever > > type that correctly. Maybe eager_hugepage_splitting? Though even that is a bit > > too long for my tastes. > > Yeah I'll pick a shorter name :). I was going back and forth on a few. > The other contender was "eager_page_splitting", since that's what I've > been calling this feature throughout the discussion of this series. > Although I can see the argument for adding "huge" in there. I didn't raise this question when reviewing but I agree. :) I'll even go with the shorter "eager_page_split" since the suffix "-ting" doesn't help anything on understanding, imho; meanwhile "huge" is implied by "split" (as small page won't need any split anyway). -- Peter Xu