On Mon, Aug 19, 2024 at 09:44:27PM +0300, Jani Nikula wrote: > v2 of [1]. Please read the cover letter there. > > This addresses review comments and adds a few more commits on top, in particular > the last one showcasing the approach. > > The main question remains, is this what we want? I don't know why, but the 'is' thing is still strange. I know I know... I'm bad with naming myself. I think about 'platform' but that get too big if (display->platform.BROADWELL) I think about 'gen' but then it is overloaded.... then I think about 'ip' is worse... 'version'? 'name'? if (display->name.HASWELL)... .... But well, I like the overall simplification here in general. Without a better name to suggest, I guess let's just move ahead... > > BR, > Jani. > > [1] https://lore.kernel.org/r/cover.1718719962.git.jani.nikula@xxxxxxxxx > > > Jani Nikula (9): > drm/i915/display: use a macro to initialize subplatforms > drm/i915/display: use a macro to define platform enumerations > drm/i915/display: join the platform and subplatform enums > drm/i915/display: add display platforms structure with platform > members > drm/i915/display: add platforms "is" member to struct intel_display > drm/i915/display: remove the display platform enum as unnecessary > drm/i915/display: consider HSW/BDW ULX to also be ULT > drm/i915/display: keep subplatforms next to their platforms > drm/i915/bios: use display->is.PLATFORM instead of IS_PLATFORM() > > drivers/gpu/drm/i915/display/intel_bios.c | 36 ++-- > .../gpu/drm/i915/display/intel_display_core.h | 3 + > .../drm/i915/display/intel_display_device.c | 89 ++++++--- > .../drm/i915/display/intel_display_device.h | 180 ++++++++++-------- > 4 files changed, 174 insertions(+), 134 deletions(-) > > -- > 2.39.2 >