On Fri, 12 Aug 2022, "Murthy, Arun R" <arun.r.murthy@xxxxxxxxx> wrote: >> diff --git a/drivers/gpu/drm/i915/display/intel_display_core.h >> b/drivers/gpu/drm/i915/display/intel_display_core.h >> index aafe548875cc..74e4ae0609b9 100644 >> --- a/drivers/gpu/drm/i915/display/intel_display_core.h >> +++ b/drivers/gpu/drm/i915/display/intel_display_core.h >> @@ -9,6 +9,7 @@ >> #include <linux/types.h> >> >> struct intel_atomic_state; >> +struct intel_cdclk_funcs; >> struct intel_crtc; >> struct intel_crtc_state; >> struct intel_initial_plane_config; >> @@ -32,6 +33,9 @@ struct intel_display { >> struct { >> /* Top level crtc-ish functions */ >> const struct intel_display_funcs *crtc; >> + >> + /* Display CDCLK functions */ >> + const struct intel_cdclk_funcs *cdclk; > > Like having intel_cdclk_funcs *cdclk, will intel_display_funcs > *display makes more sense and maintaining same terminology across the > driver. I was considering renaming it struct intel_crtc_funcs but it's not all crtc either. But display is both too generic (these are *all* display functions) and has a tautology (display.funcs.display). Dunno. BR, Jani. -- Jani Nikula, Intel Open Source Graphics Center