On Tue, May 15, 2018 at 7:19 PM, Joonas Lahtinen <joonas.lahtinen@xxxxxxxxxxxxxxx> wrote: > Quoting Souptick Joarder (2018-04-17 22:02:02) >> Use new return type vm_fault_t for fault handler. For >> now, this is just documenting that the function returns >> a VM_FAULT value rather than an errno. Once all instances >> are converted, vm_fault_t will become a distinct type. >> >> Reference id -> 1c8f422059ae ("mm: change return type to >> vm_fault_t") >> >> Fixed one checkpatch.pl warning inside WARN_ONCE. >> >> Signed-off-by: Souptick Joarder <jrdr.linux@xxxxxxxxx> >> --- >> drivers/gpu/drm/i915/i915_drv.h | 3 ++- >> drivers/gpu/drm/i915/i915_gem.c | 37 +++++++++++++++++++------------------ >> 2 files changed, 21 insertions(+), 19 deletions(-) >> >> diff --git a/drivers/gpu/drm/i915/i915_drv.h b/drivers/gpu/drm/i915/i915_drv.h >> index a42deeb..95b0d50 100644 >> --- a/drivers/gpu/drm/i915/i915_drv.h >> +++ b/drivers/gpu/drm/i915/i915_drv.h >> @@ -51,6 +51,7 @@ >> #include <drm/drm_gem.h> >> #include <drm/drm_auth.h> >> #include <drm/drm_cache.h> >> +#include <linux/mm_types.h> >> >> #include "i915_params.h" >> #include "i915_reg.h" >> @@ -3363,7 +3364,7 @@ int i915_gem_wait_for_idle(struct drm_i915_private *dev_priv, >> unsigned int flags); >> int __must_check i915_gem_suspend(struct drm_i915_private *dev_priv); >> void i915_gem_resume(struct drm_i915_private *dev_priv); >> -int i915_gem_fault(struct vm_fault *vmf); >> +vm_fault_t i915_gem_fault(struct vm_fault *vmf); >> int i915_gem_object_wait(struct drm_i915_gem_object *obj, >> unsigned int flags, >> long timeout, >> diff --git a/drivers/gpu/drm/i915/i915_gem.c b/drivers/gpu/drm/i915/i915_gem.c >> index dd89abd..61816e8 100644 >> --- a/drivers/gpu/drm/i915/i915_gem.c >> +++ b/drivers/gpu/drm/i915/i915_gem.c >> @@ -1882,7 +1882,7 @@ int i915_gem_mmap_gtt_version(void) >> * The current feature set supported by i915_gem_fault() and thus GTT mmaps >> * is exposed via I915_PARAM_MMAP_GTT_VERSION (see i915_gem_mmap_gtt_version). >> */ >> -int i915_gem_fault(struct vm_fault *vmf) >> +vm_fault_t i915_gem_fault(struct vm_fault *vmf) >> { >> #define MIN_CHUNK_PAGES ((1 << 20) >> PAGE_SHIFT) /* 1 MiB */ >> struct vm_area_struct *area = vmf->vma; >> @@ -1894,7 +1894,8 @@ int i915_gem_fault(struct vm_fault *vmf) >> struct i915_vma *vma; >> pgoff_t page_offset; >> unsigned int flags; >> - int ret; >> + int error; >> + vm_fault_t ret; > > Just add "err" under the existing variable as shorter one. Just "err" name > should suffice just like elsewhere in the code. There is a goto level "err" inside this function due to which variable is defined as error. I think better to keep "error" instead of modifying both variable and level name. >> * We eat errors when the gpu is terminally wedged to avoid >> @@ -2027,7 +2028,7 @@ int i915_gem_fault(struct vm_fault *vmf) >> ret = VM_FAULT_SIGBUS; >> break; >> default: >> - WARN_ONCE(ret, "unhandled error in i915_gem_fault: %i\n", ret); >> + WARN_ONCE(ret, "unhandled error in %s: %x\n", __func__, ret); > > I don't see point in %x (which should be 0x%x, really), why change it? ret will return VM_FAULT_FOO which is actually a defined as hex value so %x will be more meaningful to print. I think WARN_ONCE() is less meaningful to print inside default. Better to remove it ? Agree ? _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx