On Thu, 01 Mar 2018 11:28:03 +0100, Sagar Arun Kamble
<sagar.a.kamble@xxxxxxxxx> wrote:
On 3/1/2018 3:36 PM, Michal Wajdeczko wrote:
On Thu, 01 Mar 2018 09:18:18 +0100, Sagar Arun Kamble
<sagar.a.kamble@xxxxxxxxx> wrote:
GuC and HuC get loaded from intel_uc_init_hw. HuC load function is
named intel_huc_init_hw, however GuC load function is still named in
old style as intel_guc_fw_upload. Update it and the function doc. for
both functions.
Move of GuC load function's def. & decl. to intel_guc.c|h seems
necessary
as it is more about core GuC functionality and not so much about fw
itself.
This can be done in later patch if needed.
Function intel_guc_fw_upload() was named this way on purpose to follow
object-verb naming pattern, where our object is GuC FW (hence file name
intel_guc_fw.*)
There was a plan to unify this approach with HuC but in the opposite
way:
by moving HuC firmware selection code to intel_huc_fw.* but since only
one function will be left in intel_huc.c this action was deferred.
Thanks for background on this.
Note that there will be nothing wrong to call fw_upload functions from
our uc_init_hw function:
intel_uc_init_hw()
intel_uc_reset()
intel_huc_fw_upload()
Will just do HuC name change (s/intel_huc_init_hw/intel_huc_fw_upload/)
and comments update. HuC related move can be done later.
Is that ok?
Hmm, I've mixed feelings, as on one hand, this small step will unify
fw_upload calls, but at the same time it will break object-verb pattern
in intel_huc.* files ... so maybe we should do it only right?
intel_guc_fw_upload()
intel_guc_enable_comm()
intel_huc_auth()
/Michal
_______________________________________________
Intel-gfx mailing list
Intel-gfx@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/intel-gfx