Michael J Gruber <git@xxxxxxxxx> writes: > When we talk about sequencer action names as such (as opposed to command > names) we do translate the action name. Adjust the po README to reflect > this and to match the code base. > > Signed-off-by: Michael J Gruber <git@xxxxxxxxx> > --- > po/README.md | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/po/README.md b/po/README.md > index 3e4f897d93..90b8455401 100644 > --- a/po/README.md > +++ b/po/README.md > @@ -273,7 +273,7 @@ General advice: > > ```c > /* TRANSLATORS: %s will be "revert" or "cherry-pick" */ > - die(_("%s: Unable to write new index file"), action_name(opts)); > + die(_("%s: Unable to write new index file"), _(action_name(opts))); > ``` While "revert" and "cherry-pick" may have localized words in our po/ dictionary, the message uses "%s:" placeholder to identify the Git operation that is reporting the problem, and the way the end-user who is getting the message triggered the Git operation was by running a subcommand of "git", isn't it? Isn't it confusing for a user who typed "git revert" to see an error from _("revert")? _("Unable to write new index file") is perfectly fine, though.