On Thu, Aug 18 2022, Michael J Gruber wrote: > When we talk about sequencer action names as such (as opposed to command > names) we do translate the action name. Adjust the po README to reflect > this and to match the code base. > > Signed-off-by: Michael J Gruber <git@xxxxxxxxx> > --- > po/README.md | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/po/README.md b/po/README.md > index 3e4f897d93..90b8455401 100644 > --- a/po/README.md > +++ b/po/README.md > @@ -273,7 +273,7 @@ General advice: > > ```c > /* TRANSLATORS: %s will be "revert" or "cherry-pick" */ > - die(_("%s: Unable to write new index file"), action_name(opts)); > + die(_("%s: Unable to write new index file"), _(action_name(opts))); > ``` > > We provide wrappers for C, Shell and Perl programs. Here's how they're Is the end-state of this series such that we do that anywhere? Perhaps that's OK for an isolated fix, but it would really be preferred to avoid the "lego" with: die(action == REVERT ? _("revert: Unable to write new index file") : ...); Or whatever. The "TRANSLATORS" comment above the example you're modifying is now inaccurate, the "%s" will *not* be "revert" or "cherry-pick" in the post-image. I think the right thing here would be to grep our source for TRANSLATORS comments that mention %s and replace this existing example with an entirely different one...