Hi Rohit
On 06/08/2019 18:36, Rohit Ashiwal wrote:
The purpose of amend_author was to free() the malloc()'d string
obtained from get_author(). But the name does not actually convey
this purpose. Rename it to something meaningful.
The name was intended to covey that it was only used when amending a
commit, I'm fine with the rename though.
Best Wishes
Phillip
Signed-off-by: Rohit Ashiwal <rohit.ashiwal265@xxxxxxxxx>
---
sequencer.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/sequencer.c b/sequencer.c
index 65adf79222..d24a6fd585 100644
--- a/sequencer.c
+++ b/sequencer.c
@@ -1417,7 +1417,7 @@ static int try_to_commit(struct repository *r,
struct commit_extra_header *extra = NULL;
struct strbuf err = STRBUF_INIT;
struct strbuf commit_msg = STRBUF_INIT;
- char *amend_author = NULL;
+ char *author_to_free = NULL;
const char *hook_commit = NULL;
enum commit_msg_cleanup_mode cleanup;
int res = 0;
@@ -1441,7 +1441,7 @@ static int try_to_commit(struct repository *r,
strbuf_addstr(msg, orig_message);
hook_commit = "HEAD";
}
- author = amend_author = get_author(message);
+ author = author_to_free = get_author(message);
unuse_commit_buffer(current_head, message);
if (!author) {
res = error(_("unable to parse commit author"));
@@ -1526,7 +1526,7 @@ static int try_to_commit(struct repository *r,
free_commit_extra_headers(extra);
strbuf_release(&err);
strbuf_release(&commit_msg);
- free(amend_author);
+ free(author_to_free);
return res;
}