On Fri, Jul 6, 2018 at 12:19 AM Eric Sunshine <sunshine@xxxxxxxxxxxxxx> wrote: > On Thu, Jul 5, 2018 at 8:53 PM Derrick Stolee <stolee@xxxxxxxxx> wrote: > > +midx_read_expect () { > > + cat >expect <<-EOF > > + header: 4d494458 1 0 0 > > + object_dir: . > > + EOF > > + test-tool read-midx . >actual && > > + test_cmp expect actual > > +} > > + > > test_expect_success 'write midx with no packs' ' > > git multi-pack-index --object-dir=. write && > > - test_path_is_file pack/multi-pack-index > > + test_path_is_file pack/multi-pack-index && > > + midx_read_expect > > Kind of a do-nothing change. I wonder if this step would better be > delayed until a later patch. (Not necessarily a big deal.) Never mind. I missed that midx_read_expect() is comparing the 'expect' and 'actual' files, so this is not a do-nothing change. The function name may have helped to mislead me (or I was just unobservant or too focused on its creation of the 'expect' file). I wonder if a different name would have helped. midx_check(), midx_verify()? Meh.