On Sun, 6 May 2007, Michael Spang wrote: > @@ -461,7 +462,7 @@ static int read_directory_recursive(struct dir_struct *dir, const char *path, co > memcpy(fullname + baselen, de->d_name, len+1); > if (simplify_away(fullname, baselen + len, simplify)) > continue; > - if (excluded(dir, fullname) != dir->show_ignored) { > + if ((exclude = excluded(dir, fullname)) != dir->show_ignored) { Style issue: please write this as exclude = excluded(dir, fullname); if (exclude != dir->show_ignored) { instead. Yes, both are valid C, and mean the same thing, but one is much more readable than the other. Combining multiple things inside an if-statement is convenient if: - the things inside are _really_ trivial. - it's done as part of macro expansion etc (ie it's not visible as such, and the code is readable in its pre-preprocessor format) but it's not good form otherwise. Linus - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html