On Mon, 25 Nov 2024, Maxime Ripard <mripard@xxxxxxxxxx> wrote: > I wonder about the naming though (and prototype). I doesn't really > validates a mode, but rather makes sure that a given rate is a good > approximation of a pixel clock. So maybe something like > drm_mode_check_pixel_clock? Quoting myself from a few weeks back: """ Random programming thought of the day: "check" is generally a terrible word in a function name. Checking stuff is great, but what do you expect to happen if the check passes/fails? Do you expect the function to return on fail, or throw an exception? Or just log about it? If you return a value, what should the return value mean? It's hard to know without looking it up. Prefer predicates instead, is_stuff_okay() is better than check_stuff(). Or assert_stuff() if you don't return on failures. """ BR, Jani. -- Jani Nikula, Intel