v3 of [1] fixing the (!x == 0) mistake. Resending the entire thing with hopes the test robot picks up the baseline better; I haven't had much luck with --in-reply-to for that. BR, Jani. [1] https://patchwork.freedesktop.org/series/102329/ Jani Nikula (12): drm/edid: convert edid_is_zero() to edid_block_is_zero() for blocks drm/edid: have edid_block_check() detect blocks that are all zero drm/edid: refactor EDID block status printing drm/edid: add a helper to log dump an EDID block drm/edid: pass struct edid to connector_bad_edid() drm/edid: add typedef for block read function drm/edid: abstract an EDID block read helper drm/edid: use EDID block read helper in drm_do_get_edid() drm/edid: convert extension block read to EDID block read helper drm/edid: drop extra local var drm/edid: add single point of return to drm_do_get_edid() drm/edid: add EDID block count and size helpers drivers/gpu/drm/drm_edid.c | 350 ++++++++++++++++++++++++------------- 1 file changed, 225 insertions(+), 125 deletions(-) -- 2.30.2