Am 28.07.21 um 14:09 schrieb Daniel Vetter:
On Wed, Jul 28, 2021 at 1:29 PM Christian König
<ckoenig.leichtzumerken@xxxxxxxxx> wrote:
Am 27.07.21 um 13:09 schrieb Daniel Vetter:
Adding a few more people to this bikeshed.
On Mon, Jul 12, 2021 at 10:02 PM Daniel Vetter <daniel.vetter@xxxxxxxx> wrote:
@@ -349,6 +367,13 @@ int drm_sched_job_init(struct drm_sched_job *job,
struct drm_sched_entity *entity,
void *owner);
void drm_sched_job_arm(struct drm_sched_job *job);
+int drm_sched_job_await_fence(struct drm_sched_job *job,
+ struct dma_fence *fence);
+int drm_sched_job_await_implicit(struct drm_sched_job *job,
+ struct drm_gem_object *obj,
+ bool write);
+
+
I'm still waiting on the paint delivery for these two functions so I
can finish this shed.
Well I wouldn't call that bike shedding, good names are important.
Just imaging we would have called the exclusive-fence write-fence instead.
Sure naming matters, but at least to my English understanding there's
not a semantic different between telling something to await for
something else (i.e. add a dependency) or to tell something to add a
dependency (i.e. await that thing later on before you start doing your
own thing).
To be honest I had to google what await means when you first mentioned
it because I didn't had that in my English vocabulary.
(But I have to note that my English education is basically non-existent.
I speak German and a good bunch of Dutch and just interfere most of the
words).
Regards,
Christian.
Exclusive vs write fence otoh is a pretty big difference in what it means.
But also if there's consensus that I'm wrong then I'm happy to pick
the more preferred of the two options I deem equivalent.
What speaks against calling them add_dependency() and
_add_implicit_depencencies() ?
Nothing. I just like another ack on this before I rename it all. Also
I wasnt sure what you'd want to name the implicit dependency thing.
Lucas, Boris, Melissa, any acks here?
-Daniel
Regards,
Christian.
Thanks, Daniel
void drm_sched_entity_modify_sched(struct drm_sched_entity *entity,
struct drm_gpu_scheduler **sched_list,
unsigned int num_sched_list);
--
2.32.0