Hi, On Tue, Mar 23, 2021 at 2:46 PM Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> wrote: > > Hi Doug, > > On Tue, Mar 23, 2021 at 02:08:55PM -0700, Doug Anderson wrote: > > On Sun, Mar 21, 2021 at 8:02 PM Laurent Pinchart wrote: > > > > > > The valid rates are stored in an array of 8 booleans. Replace it with a > > > bitmask to save space. > > > > I'm curious: do you have evidence that this does anything useful? I > > guess you're expecting it to save .text space, right? Stack usage and > > execution time differences should be irrelevant--it's not in a > > critical section and the difference should be tiny anyway. As far as > > .text segment goes, it's not obvious to me that the compiler will use > > fewer instructions to manipulate bits compared to booleans. > > > > Doing a super simple "ls -ah" on vmlinux (unstripped): > > > > Before: 224820232 bytes > > After: 224820376 bytes > > > > ...so your change made it _bigger_. OK, so running "strip > > --strip-debug" on those: > > > > Before: 26599464 bytes > > After: 26599464 bytes > > > > ...so exactly the same. I tried finding some evidence using "readelf -ah": > > > > Before: > > [ 2] .text PROGBITS ffffffc010010000 00020000 > > 0000000000b03508 0000000000000000 WAX 0 0 65536 > > [ 3] .rodata PROGBITS ffffffc010b20000 00b30000 > > 00000000002e84b3 0000000000000000 WAMS 0 0 4096 > > > > After: > > [ 2] .text PROGBITS ffffffc010010000 00020000 > > 0000000000b03508 0000000000000000 WAX 0 0 65536 > > [ 3] .rodata PROGBITS ffffffc010b20000 00b30000 > > 00000000002e84b3 0000000000000000 WAMS 0 0 4096 > > > > Maybe you have some evidence showing an improvement? Ah, OK. I > > disassembled ti_sn_bridge_enable() and your patch saves 12 bytes, but > > I guess maybe alignment washes it out in reality... > > > > > > In terms of readability / conventions, I personally find this change a > > bit of a wash. I mean, I guess I originally implemented it as an array > > and I thought that was the most readable, but I like bitfields fine > > too. If everyone loves it then I won't object, but to me it feels like > > touching lines of code for something that's personal preference. ;-) > > You're right that the .text and CPU time improvements were not my > target. I was focussed on stack usage, as that's a limited resource in > the kernel. I don't have any evidence that we would be close to any > limit, so it's tiny, and if you or anyone else have a strong opinion > that an array of booleans is better due to readability concerns, I can > drop this change. I only thought about those poor 7 bits in every bool > that sat there unused, feeling useless :-) LOL. Thinking about it a bit more, I guess I feel a bit lame saying that the array of booleans is more readable. I guess I'd call them equivalently readable. So I guess the downside of this patch is just churn. If someone is maintaining a downstream kernel, it's an extra patch to take. If someone is running "git blame" it's an extra layer to walk back to find the history of the code. That being said, it's really not a big deal. I'll leave it up to you if you want to include the patch in your next version or if my arguments have convinced you. ;-) -Doug _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel