On Tue, May 08, 2007 at 05:41:59PM -0700, Andrew Morton wrote: > On Tue, 8 May 2007 20:48:45 +0100 > Alasdair G Kergon <agk@xxxxxxxxxx> wrote: > > +#define BIO_LIST(bl) \ > > + struct bio_list bl = BIO_LIST_INIT > BIO_LIST is a strange name for something which initialises storage. Those came by analogy with list.h, with list_head -> bio_list: #define LIST_HEAD(name) \ struct list_head name = LIST_HEAD_INIT(name) We could use something like INIT_BIO_LIST(bl) for that, but perhaps it would be more readable always written out in full? struct bio_list bl = BIO_LIST_INIT; Alasdair -- agk@xxxxxxxxxx -- dm-devel mailing list dm-devel@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/dm-devel