On Tue, 8 May 2007 20:48:45 +0100 Alasdair G Kergon <agk@xxxxxxxxxx> wrote: > +#define BIO_LIST_INIT { .head = NULL, .tail = NULL } > + > +#define BIO_LIST(bl) \ > + struct bio_list bl = BIO_LIST_INIT BIO_LIST is a strange name for something which initialises storage. > static inline void bio_list_init(struct bio_list *bl) > { > bl->head = bl->tail = NULL; > } > > +#define bio_list_for_each(bio, bl) \ > + for (bio = (bl)->head; bio && ({ prefetch(bio->bi_next); 1; }); \ > + bio = bio->bi_next) > + I have this vague memory from a long time ago that one particular CPU type wants to go oops when prefetching from an invalid address. Maybe that went away for some reason - we'd have hit it again if it was real. -- dm-devel mailing list dm-devel@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/dm-devel