Re: [PATCH v3 05/10] phy: phy-snps-eusb2: split phy init code

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 21/03/2025 15:31, Dmitry Baryshkov wrote:
On Fri, Mar 21, 2025 at 03:58:49PM +0200, Ivaylo Ivanov wrote:
The current phy init consists of hardware power-up, as well as
QCOM-specific eUSB2 init code. Split it into two parts, to make room
for such non-QCOM init code.

Signed-off-by: Ivaylo Ivanov <ivo.ivanov.ivanov1@xxxxxxxxx>
---
  drivers/phy/phy-snps-eusb2.c | 96 +++++++++++++++++++++++-------------
  1 file changed, 63 insertions(+), 33 deletions(-)

@@ -378,6 +401,11 @@ static int snps_eusb2_hsphy_probe(struct platform_device *pdev)
  	if (!phy)
  		return -ENOMEM;
+ drv_data = of_device_get_match_data(dev);
+	if (!drv_data)
+		return -EINVAL;
+	phy->data = drv_data;

Nit and completely bikeshedding, but this looks simpler:

	phy->data = of_device_get_match_data(dev);
	if (!phy->data)
		return -EINVAL;

Please use device_get_match_data() instead.

Neil



Anyway:

Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@xxxxxxxxxxxxxxxx>


+
  	phy->base = devm_platform_ioremap_resource(pdev, 0);
  	if (IS_ERR(phy->base))
  		return PTR_ERR(phy->base);
@@ -424,8 +452,10 @@ static int snps_eusb2_hsphy_probe(struct platform_device *pdev)
  }
static const struct of_device_id snps_eusb2_hsphy_of_match_table[] = {
-	{ .compatible = "qcom,sm8550-snps-eusb2-phy", },
-	{ },
+	{
+		.compatible = "qcom,sm8550-snps-eusb2-phy",
+		.data = &sm8550_snps_eusb2_phy,
+	}, { },
  };
  MODULE_DEVICE_TABLE(of, snps_eusb2_hsphy_of_match_table);
--
2.43.0







[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]


  Powered by Linux