Quoting Rakesh Pillai (2021-09-16 09:55:52) > @@ -78,6 +84,10 @@ properties: > Phandle reference to a syscon representing TCSR followed by the > three offsets within syscon for q6, modem and nc halt registers. > > + qcom,qmp: > + $ref: /schemas/types.yaml#/definitions/phandle > + description: Reference to the AOSS side-channel message RAM. > + > qcom,smem-states: > $ref: /schemas/types.yaml#/definitions/phandle-array > description: States used by the AP to signal the Hexagon core > @@ -117,6 +127,33 @@ allOf: > compatible: > contains: > enum: > + - qcom,sc7280-wpss-pil > + then: Honestly I find this if/else to be a huge tangle. Why not split the binding so that each compatible is a different file? Then it is easier to read and see what properties to set. > + properties: > + interrupts-extended: > + maxItems: 6 > + items: > + - description: Watchdog interrupt > + - description: Fatal interrupt > + - description: Ready interrupt