On Mon, Dec 4, 2017 at 10:12 PM, Quentin Schulz <quentin.schulz@xxxxxxxxxxxxxxxxxx> wrote: > To prepare for a new comer that set a different register with different > values, move rate setting in a function that is specific to each AXP > variant. > > Signed-off-by: Quentin Schulz <quentin.schulz@xxxxxxxxxxxxxxxxxx> > --- > drivers/iio/adc/axp20x_adc.c | 17 ++++++++++------- > 1 file changed, 10 insertions(+), 7 deletions(-) > > diff --git a/drivers/iio/adc/axp20x_adc.c b/drivers/iio/adc/axp20x_adc.c > index a30a972..7274f4f 100644 > --- a/drivers/iio/adc/axp20x_adc.c > +++ b/drivers/iio/adc/axp20x_adc.c > @@ -470,14 +470,18 @@ static const struct iio_info axp22x_adc_iio_info = { > .read_raw = axp22x_read_raw, > }; > > -static int axp20x_adc_rate(int rate) > +static int axp20x_adc_rate(struct axp20x_adc_iio *info, int rate) > { > - return AXP20X_ADC_RATE_HZ(rate); > + return regmap_update_bits(info->regmap, AXP20X_ADC_RATE, > + AXP20X_ADC_RATE_MASK, > + AXP20X_ADC_RATE_HZ(rate)); > } > > -static int axp22x_adc_rate(int rate) > +static int axp22x_adc_rate(struct axp20x_adc_iio *info, int rate) > { > - return AXP22X_ADC_RATE_HZ(rate); > + return regmap_update_bits(info->regmap, AXP20X_ADC_RATE, > + AXP20X_ADC_RATE_MASK, > + AXP22X_ADC_RATE_HZ(rate)); > } > > struct axp_data { > @@ -485,7 +489,7 @@ struct axp_data { > int num_channels; > struct iio_chan_spec const *channels; > unsigned long adc_en1_mask; > - int (*adc_rate)(int rate); > + int (*adc_rate)(struct axp20x_adc_iio *info, int rate); Could you also change the name of the callback, to say, adc_set_rate? This would make it much clearer what the callback does. Previously it was just a conversion helper. ChenYu > bool adc_en2; > struct iio_map *maps; > }; > @@ -554,8 +558,7 @@ static int axp20x_probe(struct platform_device *pdev) > AXP20X_ADC_EN2_MASK, AXP20X_ADC_EN2_MASK); > > /* Configure ADCs rate */ > - regmap_update_bits(info->regmap, AXP20X_ADC_RATE, AXP20X_ADC_RATE_MASK, > - info->data->adc_rate(100)); > + info->data->adc_rate(info, 100); > > ret = iio_map_array_register(indio_dev, info->data->maps); > if (ret < 0) { > -- > git-series 0.9.1 > > -- > You received this message because you are subscribed to the Google Groups "linux-sunxi" group. > To unsubscribe from this group and stop receiving emails from it, send an email to linux-sunxi+unsubscribe@xxxxxxxxxxxxxxxx. > For more options, visit https://groups.google.com/d/optout. -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html