Re: Cyrus SASL 2.1.28 testing

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Wed, 2021-11-17 at 10:32 -0800, Quanah Gibson-Mount wrote:
> --On Wednesday, November 17, 2021 1:28 PM -0500 Simo Sorce 
> <simo@xxxxxxxxxx> wrote:
> > > <>
> > 
> > Ah great.
> > 
> > For the javasasl.h issue I am not sure what to do.
> > 
> > Looking in configure there is a hack to set JAVAH to the binary "true"
> > when JAVAC is not avaialble apparently (I probably do not have JDK
> > installed in this machine) with a comment that this is to make
> > distcheck happy.
> > 
> > However the Makefile command that generates javasasl.h invokes it as
> > "$(JAVAH) -o javasasl.h ...other options..." which ends up doing
> > nothing as it is run as "true [bunch of ignored options]" and
> > javasasl.h is not generated.
> > 
> > I wonder if it ever worked, this stuff is 20 years old.
> The java/ dir was purged from the master branch because it's unsuable. 
> Perhaps we should just do that with the 2.1 branch as well.

FYI, I tried a few hacks to be able to make distcheck without java
installed, and quickly ran out of patience and ended up just git rm -r
java and removing references to it in and

I would be in favor of removing Java because we never compile that
stuff in Fedora, that said, removing a full feature sounds like 2.2
version material, not a minor z version bump ...


Simo Sorce
RHEL Crypto Team
Red Hat, Inc

Cyrus: SASL
Delivery options:

[Index of Archives]     [Info Cyrus]     [Squirrel Mail]     [Linux Media]     [Yosemite News]     [gtk]     [KDE]     [Gimp on Windows]     [Steve's Art]

  Powered by Linux