Ceph versus Zabbix: failure: no data sent

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


If the documentation is to be believed, it's just install the zabbix
sender, then;

ceph mgr module enable zabbix

ceph zabbix config-set zabbix_host my-zabbix-server

(Optional) Set the identifier to the fsid.

And poof. I should now have a discovered entity on my zabbix server to add
templates to.

However, this has not worked yet on either of my ceph clusters (one RHEL,
one proxmox).

Reference: https://docs.ceph.com/en/latest/mgr/zabbix/

On Reddit advice, I installed the Ceph templates for Zabbix.

Still no dice.  No traffic at all seems to be generated, that I've seen
from packet traces,

... OK.

I su'ed to the ceph user on both clusters, and ran zabbix_send:

zabbix_sender -v -z -s "$my_fsid" -k ceph.osd_avg_pgs -o 1

Response from "": "processed: 1; failed: 0; total: 1; seconds
spent: 0.000042"

sent: 1; skipped: 0; total: 1

As the ceph user, ceph zabbix send/discovery still fail.

I am officially stumped.

Any ideas as to which tree I should be barking up?

Thanks in advance!
ceph-users mailing list -- ceph-users@xxxxxxx
To unsubscribe send an email to ceph-users-leave@xxxxxxx

[Index of Archives]     [Information on CEPH]     [Linux Filesystem Development]     [Ceph Development]     [Ceph Large]     [Ceph Dev]     [Linux USB Development]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [xfs]

  Powered by Linux