Re: REST API Endpoint Failure - Request For Where To Look To Resolve

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi Niz (may I call you "Niz"?)

So, with the info you provided I was able to find what the issue was in the logs (now I know where the darn things are!) and so we have resolved our problem - a mis-configured port number - obvious when you think about it - and so I'd like to thank you once again for all of you patience and help



On 05/01/2024 20:39, Nizamudeen A wrote:
ah sorry for that. Outside the cephadm shell, if you do cephadm ls | grep "mgr.", that should give you the mgr container name. It should look something like this
[root@ceph-node-00 ~]# cephadm ls | grep "mgr."
        "name": "mgr.ceph-node-00.aoxbdg",
        "systemd_unit": "ceph-e877a630-abaa-11ee-b7ce-52540097c7d5@xxxxxxxx-node-00.aoxbdg",
        "service_name": "mgr",

and you can use that name to see the logs.

On Fri, Jan 5, 2024 at 3:04 PM duluxoz <duluxoz@xxxxxxxxx> wrote:

    Yeah, that's what I meant when I said I'm new to podman and
    containers - so, stupid Q: What is the "typical" name for a given
    container eg if the server is "node1" is the management container
    "mgr.node1" of something similar?

    And thanks for the help - I really *do* appreciate it. :-)

    On 05/01/2024 20:30, Nizamudeen A wrote:
    ah yeah, its usually inside the container so you'll need to check
    the mgr container for the logs.
    cephadm logs -n <mgr-container-name>

    also cephadm has
    its own log channel which can be used to get the logs.

    On Fri, Jan 5, 2024 at 2:54 PM duluxoz <duluxoz@xxxxxxxxx> wrote:

        Yeap, can do - are the relevant logs in the "usual" place or
        buried somewhere inside some sort of container (typically)?  :-)

        On 05/01/2024 20:14, Nizamudeen A wrote:
        no, the error message is not clear enough to deduce an
        error. could you perhaps share the mgr logs at the time of
        the error? It could have some tracebacks
        which can give more info to debug it further.


        On Fri, Jan 5, 2024 at 2:00 PM duluxoz <duluxoz@xxxxxxxxx>

            Hi Nizam,

            Yeap, done all that - we're now at the point of creating
            the iSCSI Target(s) for the gateway (via the Dashboard
            and/or the CLI: see the error message in the OP) - any
            ideas?  :-)



            On 05/01/2024 19:10, Nizamudeen A wrote:

            You can find the APIs associated with the iscsi here:

            and if you create iscsi service through dashboard or
            cephadm, it should add the iscsi gateways to the dashboard.
            you can view them by issuing *ceph dashboard
            iscsi-gateway-list* and you can add or remove gateways
            manually by

            ceph dashboard iscsi-gateway-add -i
            <file-containing-gateway-url> [<gateway_name>]
            ceph dashboard iscsi-gateway-rm <gateway_name>

            which you can find the documentation here:


            On Fri, Jan 5, 2024 at 12:53 PM duluxoz
            <duluxoz@xxxxxxxxx> wrote:

                Hi All,

                A little help please.

                TL/DR: Please help with error message:
                REST API failure, code : 500
                Unable to access the configuration object
                Unable to contact the local API endpoint

                The Issue

                I've been through the documentation and can't find
                what I'm looking for
                - possibly because I'm not really sure what it is I
                *am* looking for, so
                if someone can point me in the right direction I
                would really appreciate it.

                I get the above error message when I run the
                `gwcli` command from inside
                a cephadm shell.

                What I'm trying to do is set up a set of iSCSI
                Gateways in our Ceph-Reef
                18.2.1 Cluster (yes, I know its being depreciated
                as of Nov 22 - or
                whatever). We recently migrated 7 upgraded from a
                manual install of
                Quincy to a CephAdm install of Reef - everything
                went AOK *except* for
                the iSCSI Gateways. So we tore them down and then
                rebuilt them as per
                the latest documentation. So now we've got 3
                gateways as per the Service
                page of the Dashboard and I'm trying to create the

                I tried via the Dashboard but had errors, so
                instead I went in to do it
                via gwcli and hit the above error (which I now
                bevel to be the cause of
                the GUI creation I encountered.

                I have absolutely no experience with podman or
                containers in general,
                and can't work out how to fix the issue. So I'm
                requesting some help -
                not to solve the problem for me, but to point me in
                the right direction
                to solve it myself.  :-)

                So, anyone?

                ceph-users mailing list -- ceph-users@xxxxxxx
                To unsubscribe send an email to

ceph-users mailing list -- ceph-users@xxxxxxx
To unsubscribe send an email to ceph-users-leave@xxxxxxx

[Index of Archives]     [Information on CEPH]     [Linux Filesystem Development]     [Ceph Development]     [Ceph Large]     [Ceph Dev]     [Linux USB Development]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [xfs]

  Powered by Linux