Re: WebSockets don't work properly after upgrading from 14.7.5 to 15.2.1

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Thanks! I tried using tcpdump and found that in the case when things are stuck, i.e. I don’t see any requests reaching my application there are actually no packets being issued from Asterisk.

In one of my attempts, I observed that the first call went through fine. And, then suddenly Asterisk stopped sending any more events over the web socket. Seems like Asterisk is getting into some weird state.


From: asterisk-app-dev-bounces@xxxxxxxxxxxxxxxx [mailto:asterisk-app-dev-bounces@xxxxxxxxxxxxxxxx] On Behalf Of Matt Riddell
Sent: Wednesday, February 21, 2018 10:48 AM
To: Asterisk Application Development discussion <asterisk-app-dev@xxxxxxxxxxxxxxxx>
Subject: Re: [asterisk-app-dev] WebSockets don't work properly after upgrading from 14.7.5 to 15.2.1


I'd do some ngrep or something to check if the network traffic is flowing to start with.

On 21/02/2018, at 12:30 PM, Gaurav Khurana <gkhurana@xxxxxxxxxxx> wrote:


Hey all,


Did anyone else face the same issue or might know what is happening?


My application talks to Asteirsk over ARI. Everything worked perfectly with 14.7.5. But, when I upgraded Asterisk to 15.2.1, even though the web socket connection seems to have happened, the events like (ChannelCreated, etc) fail to reach my Application. This happens intermittently, i.e. sometimes when I start Asterisk and connect my application it works fine and sometimes it doesn’t.


Any ideas?




asterisk-app-dev mailing list





Matt Riddell

_______________________________________________ (Daily Asterisk News) (Call Centre Solutions)


asterisk-app-dev mailing list

[Index of Archives]     [Asterisk SS7]     [Asterisk Announcements]     [Asterisk Users]     [PJ SIP]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Linux API]

  Powered by Linux