assigning VM to a VLAN on a trunk bridge that exists on LACP bond - how to

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Dear list,

I am trying to create an access port on a VM to connect to VLAN (20 in my case). I am pretty sure my router and switch are setup correctly. I can assign my host machine (hypervisor) an IP address on either VLAN1 or VLAN20 by changing the configuration; in other words, it is connected to the switch via a trunk port.

The host machine runs on Debian 12, has ifupdown2 installed, 8021q module is loaded at boot and its /etc/network/interfaces file reads as follows:

auto lo
iface lo inet loopback

# bond interface
auto bond0
iface bond0 inet manual
        bond-slaves enp5s0 enp6s0
        bond-mode 802.3ad
	bond-xmit-hash-policy layer2+3
        bond-miimon 100
        bond-lacp-rate 1
	bond-vlan-aware yes
	bond-vids 2-500

# vlan 1
auto bridge0.1
iface bridge0.1 inet static

# bridge interface
auto bridge0
iface bridge0 inet manual
	bridge-ports bond0
	bridge_stp on
	bridge_fd 2
	bridge_maxwait 0
	bridge-vlan-aware yes
	bridge-vids 2-500

source-directory /etc/network/interfaces.d


The host gets an IP address of from VLAN1, as intended, by these settings. VM1 (also Debian 12) is connected to bridge0, which is designed as a trunk bridge, and CAN get an IP address in the network (aka VLAN1), but CANNOT get an IP address in the network 9aka VLAN20). VMs network interface is named as enp1s0 and I tried creating an interface named enp1s0.20 in its own /etc/network/interfaces file without any change in behavior. It just does not connect to VLAN20, no matter what I tried. What am I missing? I am very thankful for the pointers, and will be happy to provide further information, try recommended settings and report back.

Users mailing list -- users@xxxxxxxxxxxxxxxxx
To unsubscribe send an email to users-leave@xxxxxxxxxxxxxxxxx

[Index of Archives]     [Virt Tools]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [KDE Users]

  Powered by Linux