Re: Pulseaudio - mutliuser issues.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hello Lukas

Don't normally top post but.

Okay, installed pavcontrol and in the one account I get both the
	Built-in Audio Analog Surround 5.1
	GM206 High Definition Audio Controller Digital Stereo (HDMI)

In the second account I only get.
	GM206 High Definition Audio Controller Digital Stereo (HDMI)

I am also getting an error if I try to get a screen shot in the second account.

In the third account I only get a dummy output right after switching in and logging in for the first time.

I will have to do some more testing but it seems that the first account to use audio takes control of the 5.1 output but will confirm.

Will look at pipewire.


On 10/04/2021 11:10, Lukas Ruzicka wrote:

I have never experienced that one account would steal a sound device from other accounts, if that account is not being used at the moment.
First I would start by installing *pavucontrol* and I would try looking if the cards are visible there and if they can be chosen for output. Then, I would also consider switching to PipeWire, which is possible on Fedora 33 by installing the *pipewire* package and the *pipewire-pulseaudio* package.

On Sat, Apr 10, 2021 at 7:30 AM Robin Laing <MeSat@xxxxxxxxxxxxxxx <mailto:MeSat@xxxxxxxxxxxxxxx>> wrote:

    I use multiple accounts and recently a major headache has occurred with
    pulseaudio.  My problem started last weekend.

      From what I have found so far is that one account takes over a media
    output device.

    On my present system, I use the onboard sound for all audio but the
    says that it has audio.  Both computer monitors do have an audio output
    jack.  Sound card is connected to 5.1 speaker system.

    On average, I have two or three accounts open for work and private
    which has worked for many years with no problems.  Recently, the issue
    has arose that the one account I use for general day to day stuff has
    taken over the sound card for only it's usage.

    The second account that is for work has tried to use the HDMI output
    cannot even see the sound card as an option.  If I restart pulseaudio,
    then no devices are found until I at least lock the account and log
    back in.

    If I open a third account which I have to use for online related
    work, I
    have no sound device to use until I do a reboot.

    I have looked at trouble shooting this but I am lost.  Most online
    troubleshooting help is geared to a single account being used.

    To add to the issue, I use mplayer as my main player and in the second
    account, it refused to work if I had tried to restart pulseaudio.  It
    works with no sound if the HDMI/Display port is the only device as
    are no speakers  It is not an mplayer configuration as I have cloned
    configuration from the account that works.

    No changes to the /etc/pulse/* files since last November which would
    have been the upgrade to F33.

    Where do I start?



Save money, use Open Source Software.

Free Office Suite at
kde mailing list -- kde@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe send an email to kde-leave@xxxxxxxxxxxxxxxxxxxxxxx
Fedora Code of Conduct:
List Guidelines:
List Archives:
Do not reply to spam on the list, report it:

[Index of Archives]     [KDE Users]     [Fedora General Discussion]     [Older Fedora Users Mail]     [Fedora Advisory Board]     [Fedora Security]     [Fedora Maintainers]     [Fedora Devel Java]     [Fedora Legacy]     [Fedora Desktop]     [ATA RAID]     [Fedora Marketing]     [Fedora Mentors]     [Fedora Package Announce]     [Fedora Package Review]     [Fedora Music]     [Fedora Packaging]     [Centos]     [Fedora SELinux]     [Fedora Triage]     [Coolkey]     [Yum Users]     [Yosemite Forum]     [Fedora Art]     [Fedora Docs]     [Asterisk PBX]

  Powered by Linux